ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

#1051. Pop Sequence【栈 + 模拟】

2021-11-07 13:34:54  阅读:203  来源: 互联网

标签:1051 sequence int Sequence pop stk Pop stack numbers


原题链接

Problem Description:

Given a stack which can keep M M M numbers at most. Push N N N numbers in the order of 1 , 2 , 3 , … , N 1, 2, 3, \ldots, N 1,2,3,…,N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M M M is 5 and N N N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M M M (the maximum capacity of the stack), N N N (the length of push sequence), and K K K (the number of pop sequences to be checked). Then K K K lines follow, each contains a pop sequence of N N N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

Problem Analysis:

本题是一个栈模拟题,给定 k k k 组弹出序列,对于每一组弹出序列,我们模拟栈压入弹出的过程进行判断即可。时间复杂度为 O ( n 2 ) O(n^2) O(n2)

Code

#include <iostream>
#include <algorithm>
#include <stack>

using namespace std;

const int N = 1010;

int n, m, k;
int a[N];

bool check()
{
    stack<int> stk;
    for (int i = 1, j = 0; i <= n; i ++ )
    {
        stk.push(i);
        if (stk.size() > m) return false;
        
        while (stk.size() && stk.top() == a[j])
        {
            stk.pop();
            j ++ ;
        }
    }
    return stk.empty();
}

int main()
{
    cin >> m >> n >> k;
    while (k -- )
    {
        for (int i = 0; i < n; i ++ ) scanf("%d", &a[i]);
        if (check()) puts("YES");
        else puts("NO");
    }

    return 0;
}

标签:1051,sequence,int,Sequence,pop,stk,Pop,stack,numbers
来源: https://blog.csdn.net/geraltofrivia123/article/details/121190367

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有