ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

POJ3259 Wormholes(链式前向星+SPFA判断负环)

2020-12-11 02:03:08  阅读:245  来源: 互联网

标签:farm int 负环 POJ3259 MAXN read Wormholes FJ include


Wormholes  
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 83995   Accepted: 31141

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.     题目大意: 有n(1 ≤ n ≤ 500)个农场,m(1 ≤ m ≤ 2500)条路, w(1 ≤ w ≤ 200)个虫洞,虫洞是单向的,而路径始终是双向的(例如有(5, 6), 则必有(6, 5))。 问农夫是否能够通过一些路与虫洞,使得农夫能够看到以前的自己(时间倒流)。   思路:把每个顶点都入一次队,判断图中是否存在负环即可。 之前把重复的边也处理了,导致了WA多发(太惨了 删掉以后就A了 代码:
#include <iostream>
#include <queue>
#include <cstring>
#include <vector>
#include <set>
#include <algorithm>
#include <string>
#include <cstdio>
#include <cstdlib>
using namespace std;
#define MAXN 2503
#define INF 0x3f3f3f3f

int dis[MAXN];
int n, m, wei;

int h[4 * MAXN], w[4 * MAXN], e[4 * MAXN], ne[4 * MAXN], cnt[MAXN], idx;
bool vis[MAXN];

inline int read() {
    int s = 0, w = 1;
    char ch = getchar();
    while (ch<'0' || ch>'9') { if (ch == '-')w = -1; ch = getchar(); }
    while (ch >= '0'&&ch <= '9') s = s * 10 + ch - '0', ch = getchar();
    return s * w;
}
void add(int u, int v, int wei){
    e[idx] = v; w[idx] = wei; ne[idx] = h[u]; h[u] = idx ++;
    
}


bool spfa(){
    memset(cnt, 0, sizeof cnt);
    memset(vis, 0, sizeof vis);
    int cur;
    queue<int> q;
    for(int i = 1; i <= n; ++ i){
        q.push(i);
        vis[i] = true;
        cnt[i] ++;
    }
    while(!q.empty()){
        cur = q.front();
        q.pop();
        vis[cur] = false;
        for(int i = h[cur]; i != -1; i = ne[i]){
            int j = e[i];
            if(dis[j] > dis[cur] + w[i]){
                dis[j] = dis[cur] + w[i];
                
                cnt[j] ++;
                if(cnt[j] > n)
                    return true;
                if(!vis[j]){
                    q.push(j);
                    vis[j] = true;
                }
            }
        }
    }
    return false;
}

int main(){
    int t, S, E, T, W;
    for(cin >> t; t --;){
        idx = 0;
        memset(h, -1, sizeof h);
        cin >> n >> m >> W;
        for(int i = 0; i < m; ++ i){
            S = read();
            E = read();
            wei = read();
            add(S, E, wei);
            add(E, S, wei);
        }
        for(int i = 0; i < W; ++ i){
            S = read();
            E = read();
            wei = read();
            add(S, E, -wei);
        }
        
        cout << (spfa()?"YES":"NO") << endl;
                                                                                                                                                                            
    }
    return 0;
}

标签:farm,int,负环,POJ3259,MAXN,read,Wormholes,FJ,include
来源: https://www.cnblogs.com/daremo/p/14118368.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有