ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

浙江大学数据结构:01-复杂度2 Maximum Subsequence Sum (25分)

2020-10-06 22:34:09  阅读:214  来源: 互联网

标签:25 arr 01 int 复杂度 subsequence nSum numbers sum


浙江大学数据结构:01-复杂度2 Maximum Subsequence Sum (25分)

 

Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4
  提交代码:
#include <stdio.h>
#include <stdlib.h>
#define MAXSIZE 10000
int arr[MAXSIZE];

int main(){
    int N;
    scanf("%d", &N);
    for(int i = 0; i < N; ++i){
        scanf("%d",arr+i);
    }
    int nMax = -1;
    int nSum = 0;
    int nFirst = 0;
    int nMaxSumFirst = 0;
    int nMaxSumLast =0;
    for(int i = 0; i < N; ++i){
        nSum+=arr[i];
        if(nSum > nMax){
            nMax = nSum;
            nMaxSumFirst = nFirst;
            nMaxSumLast = i;
        }
        if(nSum < 0)
        {
            nSum = 0;
            nFirst = i + 1;
        }
    }
    if(nMax == -1){
        printf("%d %d %d", 0, arr[0], arr[N-1]);
    }
    else{
        printf("%d %d %d", nMax, arr[nMaxSumFirst], arr[nMaxSumLast]);
    }
    return 0;
}

提测结果:

 

 

标签:25,arr,01,int,复杂度,subsequence,nSum,numbers,sum
来源: https://www.cnblogs.com/2018shawn/p/13775770.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有