ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

pat 1155

2020-07-09 22:03:49  阅读:321  来源: 互联网

标签:node pat Heap 1155 tree Sample int heap


1155 Heap Paths (30分)  

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

 

题意:给定一个完全二叉树,要求从树的右边开始依次输出根结点到叶子结点的路径,并判断是不是大顶堆或者小顶堆。

思路:数组存这颗完全二叉树,以类似于中序遍历的方式递归将结点存入vector中,当到达叶子结点后输出整个vector中的元素。判断是否为堆只需要设置两个变量,加入在遍历输出的过程中发现不满足堆的需求,则改变这两个变量的值,最后如果两个变量的值有一个没被改变,则说明是相应的堆。否则不是堆

代码如下:

#include<cstdio>
#include<vector>
int node[1005];
using namespace std;
int n;
int minV=1;
int maxV=1;
void inOrder(vector<int> v,int root){
    v.push_back(root);
    if(2*root+1<=n){
        inOrder(v,2*root+1);
    }
    if(2*root<=n){
        inOrder(v,2*root);
    }
    else{
        for(vector<int>::iterator it=v.begin();it!=v.end();it++){
            if(it!=v.end()-1){
                if((it+1)!=v.end()){
                    if(node[*it]>node[*(it+1)]){
                        minV=0;
                    }
                    if(node[*it]<node[*(it+1)]){
                        maxV=0;
                    }    
                }
                printf("%d ",node[*it]);
            }
            else
                printf("%d",node[*it]);
        }
        printf("\n");
    }
}
int main(){

    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&node[i]);
    }
    vector<int> v; 
    inOrder(v,1);
    if(maxV!=0)
        printf("Max Heap\n");
    if(minV!=0)
        printf("Min Heap\n");
    if(maxV==0&&minV==0){
        printf("Not Heap\n");
    }
    return 0;
}

 

标签:node,pat,Heap,1155,tree,Sample,int,heap
来源: https://www.cnblogs.com/foodie-nils/p/13276469.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有