ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1102 Invert a Binary Tree (25分)

2020-05-16 15:08:05  阅读:304  来源: 互联网

标签:tmp Binary right int Invert start 1102 que root


The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.
 

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
 

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

反转二叉树,这题我的解法是:直接左子树插入右子树,右子树插入左子树,然后就ok啦,之后我们进行层序和中序即可。

#include "iostream"
#include "vector"
#include "string"
#include "queue"
using namespace std;
int N;
string tmp_l, tmp_r;
struct node {
    int data, left = -1, right = -1, level;
};
vector<node> v;
void levelorder(int root) {
    bool start = true;
    queue<node> que;
    que.push(v[root]);
    while(!que.empty()) {
        node n = que.front();
        if(start) {
            printf("%d", n.data);
            start = false;
        } else printf(" %d", n.data);
        que.pop();
        if(n.left != -1) que.push(v[n.left]);
        if(n.right != -1) que.push(v[n.right]);
    }
}      
bool start = true;
void inorder(int root) {
    if(v[root].left != -1) inorder(v[root].left);
    if(start) {
        start = !start;
        printf("%d", v[root].data);
    } else printf(" %d", v[root].data);
    if(v[root].right != -1) inorder(v[root].right);
}
int main() {
    scanf("%d", &N);
    v.resize(N);
    vector<bool> judge(N, false);
    for(int i = 0;i < N; i++) {
        cin >> tmp_l >> tmp_r;
        v[i].data = i;
        if(tmp_l != "-") {
            v[i].right = stoi(tmp_l);
            judge[stoi(tmp_l)] = true;
        }
        if(tmp_r != "-") {
            v[i].left = stoi(tmp_r);
            judge[stoi(tmp_r)] = true;
        }
    }
    int root_index;
    for(int i = 0; i < N; i++)
        if(judge[i] == false) root_index = i;
    levelorder(root_index);
    putchar('\n');
    inorder(root_index);
    return 0;
}

 

标签:tmp,Binary,right,int,Invert,start,1102,que,root
来源: https://www.cnblogs.com/littlepage/p/12900539.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有