ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1134 Vertex Cover (25分)

2020-05-04 17:07:02  阅读:250  来源: 互联网

标签:25 set No Cover Vertex cin vertex graph each


A vertex cover of a graph is a set of vertices such that each edge of the graph is incident to at least one vertex of the set. Now given a graph with several vertex sets, you are supposed to tell if each of them is a vertex cover or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 1), being the total numbers of vertices and the edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each in the format:

N​v​​ [ [

where N​v​​ is the number of vertices in the set, and ['s are the indices of the vertices.

Output Specification:

For each query, print in a line Yes if the set is a vertex cover, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
5
4 0 3 8 4
6 6 1 7 5 4 9
3 1 8 4
2 2 8
7 9 8 7 6 5 4 2
 

Sample Output:

No
Yes
Yes
No
No

这道题考察读题,给定顶点,边,给定一个集合,查看每个边是否至少一个点在集合内。我们按题意进行判断即可。

#include <iostream>
#include <unordered_set>
using namespace std;
int N, M, K, tmp, Nv;
pair<int, int> p[99999];
int main() {
    cin >> N >> M;
    for(int i = 0; i < M; i++) 
        cin >> p[i].first >> p[i].second;
    cin >> K;
    while(K--) {
        cin >> Nv;
        unordered_set<int> s;
        while(Nv--) {
            cin >> tmp;
            s.insert(tmp);
        }
        bool flag = true;
        for(int i = 0; i < M; i++) {
            if(s.find(p[i].first) == s.end() && s.find(p[i].second) == s.end()) {
                flag = false;
                break;
            }
        }
        printf("%s\n", flag ? "Yes" : "No");
    }
    return 0;
}

 

标签:25,set,No,Cover,Vertex,cin,vertex,graph,each
来源: https://www.cnblogs.com/littlepage/p/12827148.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有