ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT Advanced 1021 Deepest Root (25分)

2020-04-23 18:52:25  阅读:258  来源: 互联网

标签:25 1021 int max height vec components root Deepest


A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5
 

Sample Output 1:

3
4
5
 

Sample Input 2:

5
1 3
1 4
2 5
3 4
 

Sample Output 2:

Error: 2 components

我们这题可以用两次DFS,第一次DFS进行找图的连通分量,第二次DFS从第一次DFS的一个点进行寻找,找出最大的点

#include "iostream"
#include "set"
#include "vector"
using namespace std;
int N, a, b;
bool path[10100][10100] = {false};
bool vis[10100] = {false};
int max_height = -1;
set<int> s;
vector<int> vec;
void dfs(int v, int height) {
    vis[v] = true;
    if(height > max_height) {
        max_height = height;
        vec.clear();
        vec.push_back(v);
    }else if(height == max_height) vec.push_back(v);
    for(int i = 1; i <= N; i++) 
        if(path[v][i] && !vis[i])
            dfs(i, height + 1);
}
int main() {
    scanf("%d", &N);
    for(int i = 1; i <= N - 1; i++) {
        scanf("%d%d", &a, &b);
        path[a][b] = true;
        path[b][a] = true;
    }
    int components = 0;
    // find components
    for(int i = 1; i <= N; i++) {
        if(vis[i] == false) {
            dfs(i, 1);
            components++;
        }
    }
    if(components > 1) 
        printf("Error: %d components\n", components);
    else {
        // find max
        max_height = 0;
        fill(vis, vis + N + 10, false);
        for(auto x: vec) s.insert(x);
        dfs(vec[0], 1);
        for(auto x: vec) s.insert(x);
        for(auto x: s) printf("%d\n", x);
    }
    return 0;
}

 

标签:25,1021,int,max,height,vec,components,root,Deepest
来源: https://www.cnblogs.com/littlepage/p/12762804.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有