ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1059 Prime Factors (25分)

2020-02-20 17:42:09  阅读:270  来源: 互联网

标签:Prime 25 NNN int 1059 times mp printf include


题目

Given any positive integer NNN, you are supposed to find all of its prime factors, and write them in the format N=p1k1×p2k2×pmkmN = {p_1}^{k_1}\times {p_2}^{k_2}\times\cdots {p_m}^{k_m}N=p1​k1​×p2​k2​×⋯pm​km​.

Input Specification:

Each input file contains one test case which gives a positive integer NNN in the range of long int.

Output Specification:

Factor N in the format N=p1k1×p2k2××pmkmN = {p_1}^{k_1}\times{p_2}^{k_2}\times\cdots\times{p_m}^{k_m}N=p1​k1​×p2​k2​×⋯×pm​km​, where {p_i}'s are prime factors of NNN in increasing order, and the exponent kik_iki​ is the number of pip_ipi​ – hence when there is only one pip_ipi​,kik_iki​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291

题目大意

输出一个数的所有质因子。

思路

求质数还是采用常规方法,只是判断的范围可以动态变化,有这样的规律,当前因子为k则计算下一个因子从k开始,并且定义一个临时变量tt等于已求出因子的乘积,那么判断的上限就是n/t

代码

#include <iostream>
#include <cstdio>
#include <map>
#include <cmath>
using namespace std;

bool isPrime(int x){
    for(int i=2; i<=sqrt(x); i++){
        if(x%i == 0)
            return false;
    }
    return true;
}

int main(){
    map<int,int> mp;
    int n;
    scanf("%d", &n);
    int cnt = 2, t = n;
    while(t > 1){
        for(int i=cnt; i<=t; i++){ // 上下限动态变化
            if(isPrime(i) && t%i == 0){
                t /= i;
                cnt = i;
                //printf("%d\n", i);
                map<int,int>::iterator it = mp.find(i);
                if(it != mp.end())
                    mp[i]++;
                else
                    mp[i] = 1;
                break;
            }
        }
    }
    printf("%d=", n);
    for(map<int,int>::iterator it=mp.begin(); it!=mp.end(); it++){
        if(it != mp.begin())
            printf("*");
        printf("%d", it->first);
        if(it->second > 1)
            printf("^%d", it->second);
    }
    if(mp.empty())
        printf("%d", n);
    printf("\n");
    return 0;
}
李小白~ 发布了69 篇原创文章 · 获赞 35 · 访问量 1万+ 私信 关注

标签:Prime,25,NNN,int,1059,times,mp,printf,include
来源: https://blog.csdn.net/qq_40941722/article/details/104414290

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有