ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

09-排序3 Insertion or Heap Sort (25 分)

2019-11-18 22:55:56  阅读:200  来源: 互联网

标签:Sort 25 sequence int tempOri Heap child input line


According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9
#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 110;
int tempOri[maxn], origin[maxn], change[maxn];
int n;

bool Insertion();
bool isSame(int A[], int B[]);
void showArray(int A[]);
void Heap();
void downjust(int low, int high);

int main()
{

    scanf("%d",&n);
    for (int i = 1; i <= n; i++)
    {
        scanf("%d",&origin[i]);
        tempOri[i] = origin[i];
    }
    
    for (int i = 1; i <= n; i++)
    {
        scanf("%d",&change[i]);
    }
    
    if (Insertion())
    {
        printf("Insertion Sort\n");
        showArray(tempOri);
    }
    else
    {
        printf("Heap Sort\n");
        for (int i = 1; i <= n; i++)
        {
            tempOri[i] = origin[i];
        }
        Heap();
    }
    
    return 0;
}

bool Insertion()
{
    bool flag = false;
    for (int i = 2; i <= n; i++)
    {
        if (i != 2 && isSame(tempOri, change))
        {
            flag = true;
        }
        
        sort(tempOri,tempOri+i+1);
        if (flag)
        {
            return true;
        }
    }
    return false;
}

bool isSame(int A[], int B[])
{
    for (int i = 1; i <= n; i++)
    {
        if (A[i] != B[i])
        {
            return false;
        }
    }
    return true;
}

void showArray(int A[])
{
    for (int i = 1; i <= n; i++)
    {
        printf("%d",A[i]);
        if (i < n)
        {
            printf(" ");
        }
    }
}

void Heap()
{
    bool flag = false;
    for (int i = n/2; i >= 1; i--)
    {
        downjust(i,n);
    }
    
    for (int i = n; i > 1; i--)
    {
        if (i != n && isSame(tempOri, change))
        {
            flag = true;
        }
        swap(tempOri[i], tempOri[1]);
        downjust(1, i-1);
        
        if (flag)
        {
            showArray(tempOri); 
            return;
        }
    }
}

void downjust(int low, int high)
{
    int parent = low, child = parent * 2;
    while (child <= high)
    {
        if (child < high && tempOri[child+1] > tempOri[child])
        {
            child++;
        }
        
        if (tempOri[child] > tempOri[parent])
        {
            swap(tempOri[child], tempOri[parent]);
            parent = child;
            child *= 2;
        }
        else
        {
            break;
        }
    }
}

 

标签:Sort,25,sequence,int,tempOri,Heap,child,input,line
来源: https://www.cnblogs.com/wanghao-boke/p/11886170.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有