ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Foreign Exchange UVA - 10763

2019-07-17 21:02:37  阅读:230  来源: 互联网

标签:candidate Exchange int exchange 10763 program location UVA include


Your non-profit organization (iCORE - international Confederation of Revolver Enthusiasts) coordinates
a very successful foreign student exchange program. Over the last few years, demand has
sky-rocketed and now you need assistance with your task.
The program your organization runs works as follows: All candidates are asked for their original
location and the location they would like to go to. The program works out only if every student has a
suitable exchange partner. In other words, if a student wants to go from A to B, there must be another
student who wants to go from B to A. This was an easy task when there were only about 50 candidates,
however now there are up to 500000 candidates!
Input
The input file contains multiple cases. Each test case will consist of a line containing n – the number
of candidates (1 ≤ n ≤ 500000), followed by n lines representing the exchange information for each
candidate. Each of these lines will contain 2 integers, separated by a single space, representing the candidate’s
original location and the candidate’s target location respectively. Locations will be represented
by nonnegative integer numbers. You may assume that no candidate will have his or her original location
being the same as his or her target location as this would fall into the domestic exchange program.
The input is terminated by a case where n = 0; this case should not be processed.
Output
For each test case, print ‘YES’ on a single line if there is a way for the exchange program to work out,
otherwise print ‘NO’.
Sample Input
10
1 2
2 1
3 4
4 3
100 200
200 100
57 2
2 57
1 2
2 1
10
1 2
3 4
5 6
7 8
9 10
11 12
13 14
15 16
17 18
19 20
0
Sample Output
YES
NO

#include <iostream>
#include<algorithm>
#include <set>
#include<vector>
#include <map>
#include<queue>
using namespace std;
int readint() { int x; cin >> x; return x; }
typedef pair<int, int >IPair;//pair包含两种数据
int main()
{
	map<IPair, int>ex;
	int n;
	while (n = readint())
	{
		bool ans = true;
		ex.clear();
		for (int i = 0; i < n; i++)
		{
			int A = readint(), B = readint();
			ex[make_pair(A, B)]++;
		}
		for (const auto&p : ex)
		{
			IPair p2 = make_pair(p.first.second, p.first.first);
			if (p.second != ex[p2])
			{
				ans = false; break;
			}
		}
		puts(ans ? "YES" : "NO");
	}
	return 0;
}

标签:candidate,Exchange,int,exchange,10763,program,location,UVA,include
来源: https://blog.csdn.net/weixin_43981315/article/details/96360946

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有