ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1155 Heap Paths (30 分)

2019-05-19 10:56:49  阅读:303  来源: 互联网

标签:Paths Heap 10 1155 30 tree Sample 98 heap


1155 Heap Paths (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

思路

  • 层次遍历存在数组里即可,无需建树,当前结点编号d,则其左右节点编号为2d和2d+1(编号为1~N时)
  • 输出使用深度优先搜索DFS,先遍历右子树再遍历左子树,不要忘记回溯

Problem

  • “Not Heap”写成"No Heap",也因此验证了一半的测试样例是"Not Heap"
  • 忘记添加根节点路径
  • 从根节点往下判断节点是否大于或小于其父节点,反向判断会稍微复杂
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1010;
int keys[maxn]; //层序遍历的节点
bool isMax = 1, isMin = 1;
vector<int> path;
int n;

//直接在数组中dfs
void dfs(int d)
{
    if(2 * d > n){ //不再往下搜索
        if(d <= n){
            for(int i = 0; i < path.size(); ++i){
                if(i != path.size() - 1)
                    printf("%d ",path[i]);
                else printf("%d\n",path[i]);
            }
        }
        return;
    }
    //先走右子树
    path.push_back(keys[2 * d + 1]);
    dfs(2 * d + 1);
    path.pop_back();//回溯
    //再走左子树
    path.push_back(keys[2 * d]);
    dfs(2 * d);
    path.pop_back();//回溯
}

int main()
{
    scanf("%d",&n);
    for(int i = 1; i <= n; ++i){
        scanf("%d",&keys[i]);
    }
    path.push_back(keys[1]);//别忘了路径中添加根节点
    dfs(1); //从鞥节点开始搜素
    for(int i = 2; i <= n; ++i){
       if(keys[i / 2] > keys[i]) isMin = 0;
       if(keys[i / 2] < keys[i]) isMax = 0;
    }
    if(isMax) printf("Max Heap");
    else if(isMin) printf("Min Heap");
    else printf("Not Heap");
    return 0;
}

标签:Paths,Heap,10,1155,30,tree,Sample,98,heap
来源: https://blog.csdn.net/weixin_36313227/article/details/90339686

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有