ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1013 Battle Over Cities

2019-04-08 15:49:00  阅读:258  来源: 互联网

标签:city cities int Over highways need Battle 1005 Cities


1013 Battle Over Cities (25 分)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0
#include <bits/stdc++.h>
using namespace std;
int M[1005][1005];
int n;
int v[1005];
void DFS(int s)
{
	v[s]=1;
	for(int i=1;i<=n;i++)
	{
		if(M[s][i]==1&&v[i]==0)
			DFS(i); 
	}
} 
int main()
{
	int m,k;
	cin>>n>>m>>k;
	memset(M,0,sizeof(M));
	for(int i=0;i<m;i++)
	{
		int a,b;
		cin>>a>>b;
		M[a][b]=1;
		M[b][a]=1;
	}
	while(k--)
	{
		memset(v,0,sizeof(v));
		int t;
		cin>>t;
		v[t]=1;
		int cnt=0;
		for(int i=1;i<=n;i++)
		{
			if(v[i]==0)
			{
				DFS(i);
				cnt++;
			}
		}
		cout<<cnt-1<<endl;
	}
	return 0;
}

 

标签:city,cities,int,Over,highways,need,Battle,1005,Cities
来源: https://blog.csdn.net/Super_gxw/article/details/89091350

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有