ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT刷题之旅 1113-Integer Set Partition-甲级

2022-01-05 17:04:39  阅读:146  来源: 互联网

标签:Set PAT cout int S1 Partition sum2 Sample include


题目
Given a set of N (> 1) positive integers, you are supposed to partition them into two disjoint sets A1 and A2 of n1 and n2 numbers, respectively. Let S1 and S2 denote the sums of all the numbers in A1 and A2, respectively. You are supposed to make the partition so that |n1 - n2| is minimized first, and then |S1 - S2| is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2 <= N <= 105), and then N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 231.

Output Specification:

For each case, print in a line two numbers: |n1 - n2| and |S1 - S2|, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

题目大意
要求把一个集合分成两个不相交的集合,使得这两个集合的元素个数相差最小的前提下,两个集合的总和之差最大。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<map>
using namespace std;
int main()
{
    int n,a[100100];
    int sum1=0,sum2=0;
    memset(a,0,sizeof(a));
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>a[i];
    }
    sort(a,a+n);
    if(n%2==0)
    {
        cout<<"0"<<" ";
        for(int i=0;i<n/2;i++)
        {
            sum1+=a[i];
            sum2+=a[n-i-1];
        }
        cout<<sum2-sum1<<endl;
    }
    else
    {
        cout<<"1"<<" ";
        for(int i=0;i<n/2;i++)
        {
            sum1+=a[i];
            sum2+=a[n-i-2];
        }
        sum2+=a[n-1];
        cout<<sum2-sum1<<endl;
    }
    return 0;
}

标签:Set,PAT,cout,int,S1,Partition,sum2,Sample,include
来源: https://blog.csdn.net/qq_45697900/article/details/122327398

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有