ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

问题解决:Maven 加载报错 Cannot resolve com.sun:1.8

2021-09-05 18:02:08  阅读:165  来源: 互联网

标签:resolve sun 1.8 Maven 开源 报错 jconsole com


今天在写项目的时候,应用到了阿里的 druid 连接池,但是在刷新 maven 的时候一直报错 Cannot resolve com.sun:1.8Cannot resolve com.sun:jconsole:1.8

经过排查通过修改 pom 文件的方式解决

{阅读原文](https://aidanblog.top/2021/08/25/Solution-Maven-druidApply11/)

像这种知名度比较高而且应用广泛的框架,排查错误的最好方式其实是去开源仓库看别人提的 issue,发现产生如上问题的原因为 不兼容 JDK11
这种原因只能降级 JDK 或者手动修改源码,根据提示的错误信息在 pom 文件中去掉这两个包(注释掉就可以)

<dependency>
  <groupId>com.sun</groupId>
  <artifactId>tools</artifactId>
  <version>1.8</version>
  <scope>system</scope>
  <systemPath>${project.basedir}/lib/openjdk-1.8-tools.jar</systemPath>
</dependency>

<dependency>
  <groupId>com.sun</groupId>
  <artifactId>jconsole</artifactId>
  <version>1.8</version>
  <scope>system</scope>
  <systemPath>${project.basedir}/lib/openjdk-1.8-jconsole.jar</systemPath>
</dependency>

当时在学习 Java 时候我的老师说过,Java 之所以在国内火爆,主要是因为许多大厂在使用 Java,这样也就有大量能力和精力足够的团队去开发实用框架和解决一些疑难问题
druid 也算是阿里开源中最大众化的(大部分人接触的第一款阿里开源)
其实真正遇到问题的时候可以去提 issue、贡献代码,而不是直接去社区或群里喷制作团队,怎么说呢,一个优质的技术开源环境,应该是人人争做创造者,而不是一个难以满足的使用者(有感而发)

标签:resolve,sun,1.8,Maven,开源,报错,jconsole,com
来源: https://blog.csdn.net/huaxin0304/article/details/120118569

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有