ICode9

精准搜索请尝试: 精确搜索
  • jdk安装2020-10-19 15:02:55

    jdk安装 1. 查看是否已经安装了java yum list installed |grep java 如有有jdk版本输出证明已经安装过了。 2. yum查看可用版本,并安装 yum -y list java* yum -y install java-1.8.0-openjdk* 3. 查看版本 [root@hadoop10 mongod]# java -version openjdk version "1.8.0_262" O

  • Linux(CentOS 7)Java-JDK的jps失效问题2020-10-14 10:34:51

    1、今日使用组长新创建的一台虚拟机,安装了软件后,使用jps命令查询,出现问题: # jps bash: jps: 未找到命令...     2、然后查询了一下,当前机器的安装的软件环境 查询自带安装的jdk # yum list | grep jdk-devel java-1.6.0-openjdk-devel.x86_64 1:1.6.0.41-1.13.13.1.el7_3 base

  • centos 安装java2020-10-12 10:03:08

     本文出自:https://www.cnblogs.com/2186009311CFF/p/13801112.html 查看yum里面有那些java的版本 yum -y list java* 安装的是1.8的java版本 yum -y install java-1.8.0-openjdk* 验证java版本看看是否安装完成 java -version   参考:https://blog.csdn.net/u014449653/art

  • Pinpoint安装采集docker的springboot2020-10-01 10:02:09

    原文链接:https://www.jianshu.com/p/70de245af566?utm_campaign=maleskine&utm_content=note&utm_medium=seo_notes&utm_source=recommendation 前言 在上一篇文章里面介绍了pinpoint的基础安装流程,虽然遇到了一些问题,后续总算完成了安装部署可以在正式环境中使用,也采集到了许多

  • centos7通过yum安装JDK1.82020-09-27 12:01:25

    1、安装之前先检查一下系统有没有自带open-jdk 命令: rpm -qa |grep java rpm -qa |grep jdk rpm -qa |grep gcj 如果没有输入信息表示没有安装。 如果安装可以使用rpm -qa | grep java | xargs rpm -e --nodeps 批量卸载所有带有Java的文件  这句命令的关键字是java

  • Maven 指定java编译版本2020-09-21 03:00:36

    使用默认的属性名 <properties> <maven.compiler.source>1.8</maven.compiler.source> <maven.compiler.target>1.8</maven.compiler.target> </properties> 在pom.xml 的plugins节点下面添加 <plugins> <plugin> <

  • Linux7安装JDK报错:bad ELF interpreter: 没有那个文件或目录2020-09-17 22:02:39

    问题描述 Linux下安装jdk1.8查看版本的时候报出: -bash: /usr/local/jdk1.8.0_144/bin/java: /lib/ld-linux.so.2: bad ELF interpreter: 没有那个文件或目录 解决方案 sudo yum install glibc.i686 再次使用命令java -version查看JDK版本时,显示出JDK版本 [root@slave1 java]# ja

  • 自动化测试之Pytest入门2020-09-12 21:00:50

    pytest是一个功能非常全面的Python自动化测试框架 特点: 1、简单灵活,支持参数化,可以细粒度的控制测试用例; 2、不仅支持简单的单元测试,还支持复杂的功能测试,不仅可以用来做selenium/appium的UI自动化测试,还可以用作做基于Python+requests的接口自动化测试; 3、第三方插件非常丰富,如py

  • pip 笔记2020-09-04 02:00:31

    windows 配置国内镜像/下载源 win+R 呼出运行,输入 %APPDATA%,会打开一个文件夹,如 C:\Users\richmanwu\AppData\Roaming 找到该目录下的 pip 文件夹,进去 里面有一个 pip.ini 文件,没有就新建 用编辑器打开这个文件,输入以下内容 [global] time-out=60 # 设置超时为60秒 index-url =

  • M001-CentOS下配置Maven2020-09-02 06:01:23

      1.安装JDK   Linux上一般会安装Open JDK,不建议使用OpenJDK。   关于OpenJDK和JDK的区别:http://www.cnblogs.com/sxdcgaq8080/p/7487369.html   1.1查询是否安装openJDK和相应的rpm包 [root@CentOS7 ~]# java -version openjdk version "1.8.0_242" OpenJDK Runtime Env

  • maven打包可运行jar包2020-08-24 11:34:58

    一、pom文件 <build> <plugins> <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-compiler-plugin</artifactId> <version>

  • IntelliJ IDEA 编译报错:Error:java: Compilation failed: internal java compiler error2020-08-17 21:35:02

    报错内容: Information:java: javacTask: 源发行版 8 需要目标发行版 1.8 Information:java: Errors occurred while compiling module 'gulimall-common'Information:javac 1.8.0_91 was used to compile java sourcesInformation:Module "gulimall-common" was fully

  • 今天把一个很弱智的java程序部署到服务器上,只是能运行了,但是还没开始通信2020-08-14 23:00:34

    我就在idea上导出jar包,因为我电脑和服务器上都装的是jdk14,但是我也不懂为什么服务器上yum里写的是14装完就还是1.8了,结果我这边打包完在服务器就是说什么jre不对,然后我在idea里的language level这一个选项选了对应的1.8,然后重新build,就好了,那个选项可能是向下兼容的意思?有待后续学

  • 关于 maven-compiler-plugin 插件的使用详解2020-08-14 10:02:33

    两种方式 maven 项目是通过 maven-compiler-plugin 插件来对 Java 代码编译的,如果不指定 JDK 版本,maven-compiler-plugin 会自动使用一个默认的版本,该版本可能与你使用的 IDE 所使用的 JDK 版本不一致,这种情况可能会导致代码无法通过 maven 的编译,例如:在 IDE 指定 JDK 1.8 ,coding

  • Failed to execute goal org.apache.maven.plugins:maven2020-08-12 16:32:14

    Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project jnpf-module-basics: Fatal error compiling 用idea进行maven打包时出现此问题 解决方法一、 添加 <plugin> <groupId>org.apache.maven.pl

  • centos7使用yum安装jdk并配置jdkhome2020-08-12 09:33:17

    背景 yum安装很方便,实在是懒得一直拷贝安装包了。 安装方法 yum install java-1.8.0-openjdk.x86_64 查找jdk安装的位置 [root@localhost]# which java /bin/java [root@localhost]# ls -l /bin/java lrwxrwxrwx. 1 root root 22 Mar 22 01:01 /bin/java -> /etc/alternatives/ja

  • ModuleNotFoundError: No module named 'keras'2020-08-08 08:31:26

          tensorflow 和 Keras对应的版本关系:         : tensorflow 1.5 和 keras 2.1.4 ,                                             1.4 和 2.1.3搭配,                                             1.3 和 2.1.2 搭

  • [CVE-2020-1948]Apache Dubbo Provider默认反序列化RCE2020-06-26 12:40:23

    git clone https://github.com/apache/dubbo-spring-boot-project cd dubbo-spring-boot-project git checkout 2.7.1 -b b2.7.1 # 将整个项目dubbo-spring-boot-project导入IDEA 在dubbo-spring-boot-samples/auto-configure-samples/provider-sample/pom.xml 引入以下依

  • 浅谈jvm垃圾回收2020-06-23 14:02:02

    jvm内存分为,1堆区 2栈区 3方法区(元空间)4本地方法栈 5程序计数器 本地方法栈只的时java通过jni调用的本地c/c++代码所处于的空间;而程序计数器的作用是标记程序运行的位置,以及下一次执行的位置。 栈区来说是线程私有的空间,不存在并发的问题,当我们调用一个个方法的时候就会将方法以栈

  • maven配置错误之Unable to import maven project: See logs for details2020-06-17 19:57:39

    很多朋友在初次使用maven时,都会出现这个问题。 一加载maven项目,即会报出Unable to import maven project这样的错误,哪怕是新的maven项目也不例外。 我查阅了很多博客,给出的解决办法无非是重查MAVEN_HOME、path的配置,idea内settings的配置,我想只要认真配置是不出现这种问题的。 我

  • Maven Build时显示【ERROR】不再支持源选项5。请使用7或更高版本2020-06-17 09:55:00

    解决办法1(暂时性解决) 在pom.xml文件中添加jdk版本说明,我的jdk版本是1.8,所以添加时根据自己的jdk版本进行修改。 <properties>   <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>   <maven.compiler.encoding>UTF-8</maven.compiler.en

  • CentOS 8配置Java环境2020-06-16 12:10:03

    Linux环境:CnetOS 8 VmWare 1. 查看yum源的java包 yum list java* 2. 选择1.8.0版本进行安装 yum -y install java-1.8.0-openjdk 提示:错误,该命令必须以root用户运行 备注:这是因为登陆用户没有root权限 解决办法:普通用户暂时使用su命令获得root权限(以下两种命令均可) su

  • 一个月出货1500多万部5G手机,全年1.8亿部能完成吗2020-06-14 15:04:41

    5G牌照已经颁发一周年了。虽然今年有疫情的影响,但国内运营商建设5G的步伐并没有因此而放慢速度。诚然,一度时间暂时停摆了一个时期,但疫情被逐步控制之后,运营商对于5G的建设正在不断加快。尤其是在新基建的发展中,5G建设被当作一个重要支点,无论是运营商还是设备商都对5G建设表现出极

  • php内部解析,附带1.8可能出现的问题的不定时2020-06-10 15:57:46

    按问题的形式来吧,这些大多是我自己总结的,如有错误请及时指正谢谢 1.你了解HashMap么,可以说说么?   首先,HashMap是一种数据结构,可以快速的帮我们存取数据。它的底层数据结构在1.7和1.8有了一些变化,1.7版本及以前他是数组+链表的形式,1.8及以后数组+链表+红黑树,如果链表长度大于等于

  • 基于【 bug解决】一 || Springboot整合mqtt协议导致的错误2020-06-10 14:09:07

    目录1、报错信息如下所示: 1、报错信息如下所示: by: javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No name matching XXX found org.eclipse.paho.client.mqttv3.MqttException: MqttException at org.eclipse.paho.client.mqttv3.internal.Ex

专注分享技术,共同学习,共同进步。侵权联系[admin#icode9.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有