ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1104 Sum of Number Segments (20 分)有超时

2019-02-01 19:42:51  阅读:253  来源: 互联网

标签:20 0.1 Sum 0.2 Number 0.4 sum include 0.3


1104 Sum of Number Segments (20 分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

最后两个样例会超时
#include<iostream>
#include<vector>
#include<algorithm>
#include<map>
#include<set>
#include<cmath>
#include<climits>
#include<sstream>
#include<cstdio>
#include<string.h>
#include<unordered_map>
using namespace std;
long long int maxn=1000000;
int main()
{
    int n;
    scanf("%d",&n);
    double a;
    double sum[n+1];
    memset(sum,0,sizeof(sum));
    double result=0;
    for(int i=1;i<n+1;i++)
    {
        scanf("%lf",&a);
        sum[i]=sum[i-1]+a;
        result+=sum[i];
    }
    for(int i=1;i<n;i++)
    {
        for(int j=i+1;j<n+1;j++)
        {
            result+=sum[j]-sum[i];
            //cout<<sum[j]-sum[i]<<endl;
        }
    }
    printf("%.2f",result);

    return 0;
}

 

 

标签:20,0.1,Sum,0.2,Number,0.4,sum,include,0.3
来源: https://www.cnblogs.com/zhanghaijie/p/10346794.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有