ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT 1147 Heaps

2019-01-29 20:39:18  阅读:379  来源: 互联网

标签:Heaps PAT 1147 level int tree flag heap Heap


https://pintia.cn/problem-sets/994805342720868352/problems/994805342821531648

 

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

代码:

#include <bits/stdc++.h>
using namespace std;

int N, M;
vector<int> level;

void postorder(int st) {
    if(st >= N) return ;
    postorder(st * 2 + 1);
    postorder(st * 2 + 2);
    printf("%d%s", level[st], st == 0 ? "\n" : " ");
}

int main() {
    scanf("%d%d", &M, &N);
    level.resize(N);
    while(M --) {
        for(int i = 0; i < N; i ++)
            scanf("%d", &level[i]);

        int flag;
        if(level[0] > level[1]) flag = 1; // max
        else if(level[0] < level[1]) flag = -1; // min

        for(int i = 0; i <= (N - 1) / 2; i ++) {
            int l = i * 2 + 1, r = i * 2 + 2;
            if(flag == 1 && (level[i] < level[l] || r < N && level[r] > level[i])) flag = 0;
            if(flag == -1 && (level[i] > level[l] || r < N && level[r] < level[i])) flag = 0;
        }

        if(flag == 0) printf("Not Heap\n");
        else if(flag == 1) printf("Max Heap\n");
        else if(flag == -1) printf("Min Heap\n");

        postorder(0);
    }
    return 0;
}

  堆最后一层不满的话是都靠左排的 头是 level[0] 先判断 level[0] 和 level[1] 的大小关系初步假设是最大堆还是最小堆 然后进行判断 0 到 (N - 1) / 2 的点都是有孩子节点的 如果父亲节点是 index 那么左儿子是 index * 2 + 1 右儿子是 index * 2 + 2 

FHFHFH

标签:Heaps,PAT,1147,level,int,tree,flag,heap,Heap
来源: https://www.cnblogs.com/zlrrrr/p/10335734.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有