ICode9

精准搜索请尝试: 精确搜索
首页 > 编程语言> 文章详细

PAT (Advanced Level) Practice 1008 Elevator 分数 20 Python 解法

2022-08-01 14:33:58  阅读:189  来源: 互联网

标签:PAT nums Python Level list elevator floors numbers ans


题目

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop. For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

 

解题思路

先求出相邻楼层之间的间隔,然后用模拟的方式求出结果

 

nums = list(map(int, input().split()))[1:]


floors = [nums[0]] + [nums[i] - nums[i - 1] for i in range(1, len(nums))]

#print(floors)
ans = 0
for i in floors:
    if i > 0:
        ans += 6 * i
    else:
        ans -= 4 * i
    ans += 5

print(ans)

 

标签:PAT,nums,Python,Level,list,elevator,floors,numbers,ans
来源: https://www.cnblogs.com/sakuraki/p/16540153.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有