ICode9

精准搜索请尝试: 精确搜索
  • JavaScript快速入门-01-环境搭建2022-08-14 23:30:09

    1 环境搭建     搭建JavaScript开发环境有很多种组合,本文中采用Visual Studio Code和Node.js的组合,详细如下所示: 1.1 Node.js环境搭建 1.1.1 下载Node.js     不管是基于Windows还是Linux,都需要下载相应的安装包,到Node.js官网根据系统下载相应版本的Node.js版本。下载地址如下

  • tauri学习(1)-初体验2022-08-14 19:05:05

    tauri是一个类似Electron的框架,对于开发者最大的区别是后端语言用的是Rust,而且生成的可执行程序更小,今天尝试了下,感觉还不错,按官网的做法,只需执行下的命令(mac环境) npm create tauri-app 回答一些基础问题后,项目模板就搭建好了,参考下图,我选的是create-react-app + TypeScript

  • @babel/runtime 和 @babel/plugin-transform-runtime 两个的作用是什么2022-08-14 18:30:08

    Babel 最基础的功能就是将采用 ECMAScript 2015+ 语法编写的代码转换为向后兼容的 JavaScript 语法,以便能够运行在当前和旧版本的浏览器或其他环境中。 最基础的依赖包也就是以下两个: npm i -D @babel/core @babel/preset-env 比如我们声明了两个 Class 类,每当我们打包之后,都重复

  • node.js2022-08-14 14:31:13

    1. node.js是开发脱离浏览器的js程序,是一个运行环境,或者说是一个 JS 语言解释器。 2. node最常见的几个小命令 ①dir 列出当前目录下的所有文件 ②cd + 目录名进入到指定目录 ③md + 目录名 创建目录 ④rd + 目录名 删除目录 3. node模块发开发,提高代码的复用率 ①requite() 引入

  • 2022.8.14 NPM包管理器与Babel2022-08-14 12:03:44

    04、NPM包管理器 4.1、简介 官方网站:https://www.npmjs.com/ NPM全称Node Package Manager,是Node.js包管理工具,是全球最大的模块生态系统,里面所有的模块都是开源免费的;也是Node.js的包管理工具,相当于java的Maven 。  #在命令提示符输入 npm -v 可查看当前npm版本 4.2、使用npm管

  • 2022.8.14 模块化、Webpack、Vue-element-admin2022-08-14 12:02:28

    06、模块化 相当于形成包 6.1、简介 模块化产生的背景 随着网站逐渐变成”互联网应用程序”,嵌入网页的Javascript代码越来越庞大,越来越复杂。 Javascript模块化编程,已经成为一个迫切的需求。理想情况下,开发者只需要实现核心的业务逻辑,其他都可以加载别人已经写好的模块。但是,Javas

  • Vue和ElementUI2022-08-13 21:02:01

    1、创建工程    这个时候就安装路由 比idea运行后安装好,编码会出现代码提示 前端东西不能用纯CSS来写,安装SASS加载器,通过SASS编译 3、npm命令:  

  • vue学习之------vite2022-08-13 20:01:17

    vue两种快速创建工程化SPA(单页面应用)项目的方法: vite:仅支持vue3;运行速度快;不是基于webpack打包 vue-cli:vue2、vue3都支持;运行速度较慢;基于webpack打包   用vite创建项目:npm init vite-app 项目名 进入项目文件:cd 项目文件 安装所有依赖包:npm install 启动项目:npm run dev 项

  • 使用 npm 包①- Vant Weapp-微信小程序开发(二十七 )2022-08-13 16:02:46

    小程序对 npm 的支持与限制 目前,小程序中已经支持使用 npm 安装第三方包,从而来提高小程序的开发效率。但是,在小程序中使用 npm 包有如下 3 个限制: ① 不支持依赖于 Node.js 内置库的包 ② 不支持依赖于浏览器内置对象的包 ③ 不支持依赖于 C++ 插件的包 总结:虽然 npm 上的包有千千

  • Vue-router路由2022-08-13 01:01:36

    一、路由原理。   1.传统开发方式url改变后立刻发起请求响应整个页面,渲染整个页面。有可能资源过多,传统开发又会让页面出现白屏。   2.SPA Single Page Application 单页面应用:锚点值的改变后不会立刻发送请求,而是在某个合适的时机发起ajax请求,局部改变页面的数据。页面不会立

  • nodejs下载安装2022-08-12 16:30:41

    https://blog.csdn.net/Tersion/article/details/126226404 安装后,可使用npm install 安装其他newman、yarn等,若出现如下提示    根据提示输入npm install -g [email protected]即可

  • 2022-08-12 Syntax Error: TypeError: Cannot set property 'parent' of undefined2022-08-12 12:02:02

    前言:vue项目,有12周没更新了,再次运行,报错:Syntax Error: TypeError: Cannot set property 'parent' of undefined 语法错误:TypeError:无法设置未定义的属性“parent” 原因:css编译器less出了问题。我把报错的那个文件的less样式删掉,就不报错了。但显然这样并不能解决问题。 其他vue

  • ubuntu下安装 electron时报 Cannot read property 'insert' of undefined2022-08-12 11:32:10

    npm ERR! Cannot read property 'insert' of undefined npm ERR! A complete log of this run can be found in:npm ERR! /home/jbjiang/.npm/_logs/2022-08-12T02_44_16_135Z-debug-0.log   问题原因   没有使用root权限。调用npm install 权限不足导致 的   解决方法 sud

  • 如何搭建一个vue项目2022-08-11 19:02:55

    一 安装nvm(node的版本管理工具:一个nvm可以管理很多node版本) curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.39.1/install.sh | bash   1 注意: v0.39.1这是nvm的版本号,当前最新版本是v0.39.1。详见  2 常用的nvm命令: 命令描述 nvm ls-remote 列出远程服务器

  • js高精度计算npm包2022-08-08 10:30:08

    Why 0.1 + 0.2 = 0.30000000000000004 1.0 - 0.9 = 0.09999999999999998 0.105.toFixed(2) = 0.1 // not 0.11 注意传参传null。会报错 最好数值类型的参数 https://npmmirror.com/package/number-precision

  • IDEA中Vue的安装和使用(最全篇)2022-08-07 18:00:53

    一.准备工作     Vue是前端开发框架。搭建框架,首先要搭建环境。搭建Vue的环境工具:node.js(JavaScript的运行环境),然后再用nodejs里面的npm(包管理和分发工具)来安装依赖包。 二.安装node.js     下载地址:https://nodejs.org/zh-cn/      最好下载稳定版本:下载完之后(安装程序可

  • IDEA使用vue的安装与配置(详细教程)2022-08-07 17:03:46

    在idea中使用vue首先idea的配置以及环境要搭建好,然后就按照以下操作进行就可以!(注:我使用的idea是2021.1.3 版本) 第一步 去官网下载node.js ,官网地址:https://nodejs.org/en/       然后进行安装,安装过程只需要一直点下一步就行,不需要勾选任何选项(目录可以更改,最好使用默认) 第

  • 【VUE】vue报错‘vue-cli-service‘不是内部或外部命令,也不是...的解决办法2022-08-06 22:01:42

    【VUE】vue报错'vue-cli-service'不是内部或外部命令,也不是...的解决办法 问题描述 项目执行npm run serve后报错 产生原因 (最大概率原因) 由于在该代码中含有node_module依赖包,再拷贝到其他计算机时,项目路径发生变化,导致找不到vue-cli-service于是报错 (其他出错情况,见下文扩展) 因

  • npm常规命令行集合2022-08-05 16:35:30

      1,常规文件操作命令 cd..                   返回当前文件的上一级(向上走) cd sell               打开"sell"文件夹(向下走) dir                     打开当前文件夹下面的所有文件 F:                   直接进入F盘 2,安装文件的命令 npm ins

  • vue 使用sass定义全局变量2022-08-05 01:32:00

    一、安装以下依赖: npm i -D [email protected] -D npm i [email protected] -D npm i sass-resources-loader -D 二、新建文件:variables.scss $primary-color:#547fcd; $secondary-color:#6992dd; $text-blue-color:#648eda; $highlight-color:#7cffe2; 三、配置 vue.config.js:

  • 解决yarn安装包后,文件名、目录名或卷标语法不正确问题2022-08-04 12:31:22

    1.问题复现 ①安装场景:想用yarn安装vite项目时报错      2.查明原因: yarn 的全局安装位置与 bin 的位置并不一致导致的 3.原因自查方法: 1.先查看npm的位置 // 查看全局安装位置 npm config get prefix // E:\Tools\node\node_global // 查看缓存位置 npm config get cache //

  • vue2022-08-04 10:34:04

            之后运行脚本 npm run XXX(脚本名字)

  • nrm管理切换源地址2022-08-02 14:03:00

    1、全局安装nrm npm i -g nrm mac上使用 sudo npm i -g nrm 2、查看可用的源地址 nrm ls      3、切换源地址 nrm use taobao  

  • windows下使用pm2守护进程对laravel队列进行管理2022-08-01 21:32:39

    我们都知道在使用laravel的消息队列时,都需要一个守护进程对其进行管理 否则在服务器重启或者其他异常都会导致队列中断从而功能失效 当然,大部分项目都是在linux下运行,则可以直接使用supervisor进行管理 laravel的官方文档中对supervisor也有详细的介绍,在此就不赘述了 那么在window

  • node版本管理(nvm)2022-08-01 17:00:44

    简介 在实际的前端开发过程中,可能会经常遇见 node.js 的版本问题,不同的项目需要使用不同的 node.js 版本,而直接安装的话,只能安装和使用 node.js 的一个版本。此时,就可以使用 nvm 来安装和管理不同版本的 node.js。 下载及安装 下载地址:https://github.com/coreybutler/nvm-windows

专注分享技术,共同学习,共同进步。侵权联系[[email protected]]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有