ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Codeup100000575问题 E: Shortest Distance (20)

2021-05-06 21:59:55  阅读:152  来源: 互联网

标签:Distance 20 exits int sum sum1 Codeup100000575 between dis


题目描述

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 1 0 5 10^5 105]), followed by N integer distances D 1 D_1 D1​ D 2 D_2 D2​ … D N D_N DN​, where D i D_i Di​ is the distance between the i-th and the (i+1)-st exits, and D N D_N DN​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<= 1 0 4 10^4 104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1 0 7 10^7 107.

输出

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

样例输入

5 1 2 4 14 9
3
1 3
2 5
4 1

样例输出

3
10
7

实现代码

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn = 1e5 + 10;

/*
    此题对时间复杂度的要求很高,O(2n)的复杂度会造成超时,
    故只能在输入时计算好结点i(i>=1)到1的距离来加快计算
*/

int main() {
    int n;
    int D[maxn];
    int dis[maxn];
    int m;
    int l, r;
    while(scanf("%d", &n) != EOF) {
        int sum = 0;
        dis[1] = 0;
        for(int i = 1; i <= n; i++) {
            scanf("%d", &D[i]);
            sum += D[i];
            dis[i + 1] = sum;
        }
        scanf("%d", &m);
        for(int i = 0; i < m; i++) {
            scanf("%d%d", &l, &r);
            if(l > r) {
                swap(l, r);
            }
            int sum1 = dis[r] - dis[l];
            if(sum1 > sum - sum1) {
                printf("%d\n", sum - sum1);
            } else {
                printf("%d\n", sum1);
            }
        }
    }
    return 0;
}

标签:Distance,20,exits,int,sum,sum1,Codeup100000575,between,dis
来源: https://blog.csdn.net/Lerbronjames/article/details/116464014

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有