ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HDU4864 Task【贪心】

2021-04-13 13:34:16  阅读:171  来源: 互联网

标签:machine task complete int HDU4864 ++ Task mach 贪心


Task
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16874 Accepted Submission(s): 4287

Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500xi+2yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.

Input
The input contains several test cases.
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.

Sample Input
1 2
100 3
100 2
100 1

Sample Output
1 50004

Author
FZU

Source
2014 Multi-University Training Contest 1

问题链接HDU4864 Task
问题简述:(略)
问题分析:这是一个服务(机器提供服务)与任务的问题,用贪心法来解决,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU4864 Task */

#include <bits/stdc++.h>

using namespace std;

const int N = 100000;
struct Node {
    int x, y;
} mach[N], task[N];
const int Y = 100 + 1;
int lvl[Y];

bool cmp(Node a, Node b)
{
    return a.x == b.x ? a.y > b.y : a.x > b.x;
}

int main()
{
    int n, m;
    while (~scanf("%d%d", &n, &m)) {
        for (int i = 0; i < n; i++)
            scanf("%d%d", &mach[i].x, &mach[i].y);
        for (int i = 0; i < m; i++)
            scanf("%d%d", &task[i].x, &task[i].y);

        sort(mach, mach + n, cmp);
        sort(task, task + m, cmp);

        long long sum = 0;
        int cnt = 0, j = 0;
        memset(lvl, 0, sizeof lvl);
        for (int i = 0; i < m; i++) {
            while (j < n && mach[j].x >= task[i].x) lvl[mach[j++].y]++;


            for (int k = task[i].y; k <= Y; k++)
                if (lvl[k]) {
                    cnt++;
                    sum += 500 * task[i].x + 2 * task[i].y;
                    lvl[k]--;
                    break;
                }
        }

        printf("%d %lld\n", cnt, sum);
    }

    return 0;
}

标签:machine,task,complete,int,HDU4864,++,Task,mach,贪心
来源: https://blog.csdn.net/tigerisland45/article/details/115662714

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有