ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1077 Kuchiguse (20 分)

2021-03-01 21:32:06  阅读:219  来源: 互联网

标签:case nyan 20 int 1077 lines Sample Kuchiguse character


The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
 

Sample Output 1:

nyan~
 

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T
 

Sample Output 2:

nai

注意getline对回车键的读入

#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
int main(){
    int n;
    scanf("%d\n",&n);//注意:一定要加\n  ;  如果发现输出少了,一定要检查是否读入空格
    string str,ans;
    for(int i=0;i<n;i++){
        getline(cin,str);
        int lens=str.length();
        reverse(str.begin(),str.end());
        if(i==0){
            ans=str;
        }
        else{
            int lena=ans.length();
            if(lens<lena){
                swap(str,ans);
            }
            int len=min(lena,lens);
            for(int j=0;j<len;j++){
                if(str[j]!=ans[j]){
                    ans=ans.substr(0,j);//左闭右开
                    break;
                }
            }
        }
    }
    reverse(ans.begin(),ans.end());
    if(ans.length()>0){
            cout<<ans<<endl;
        }
        else{
            cout<<"nai"<<endl;
        }
    
    return 0;
}

 

标签:case,nyan,20,int,1077,lines,Sample,Kuchiguse,character
来源: https://www.cnblogs.com/dreamzj/p/14466013.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有