ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1022 Digital Library (30 分)

2021-02-26 23:32:54  阅读:189  来源: 互联网

标签:string 30 cin Library getline book Digital keywords id


1022 Digital Library (30 分)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10^​4​​ ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

Output Specification:
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla

题目大意:
给定n本书的信息(包含id,书名,作者,关键词,出版商,发行日期),给定m个查询命令,每个命令前都有数字标注,命令后紧跟搜索词。要求输出该命令,以及搜索词对应的书的id;若没找到,则输出Not Found。

算法分析:
根据搜索词的种类不同建立多个map<string,set>,string中存储搜索词信息,set中存储搜索词对应的id信息。

定义query函数,首先判断搜索词在不在对应的map中,若不在,直接输出Not Found;若在,则将对应的set中的内容输出

注意:
本题的输入是个难点,需要注意cin>>和getline()的不同(getline()中的结束符,结束后,结束符不放入缓存区;cin的结束符,结束后,结束符还在缓存区)

query函数中要传引用,不然最后一个点过不了。直接传值的话,需要再开空间搞个map出来,数据量一大就出问题了

AC代码:

#include<bits/stdc++.h>
using namespace std;
map<string,set<int>>title,author,keywords,publisher,year;//一个信息对应一个集合,元素是id 
int bookNum,queryNum;
void query(map<string,set<int>> &m,string &des){//传参数的时候直接传引用,不用再给变量开辟空间,更加节省时间 
	if(m.find(des)==m.end())printf("Not Found\n");
	else{
		for(auto it=m[des].begin();it!=m[des].end();it++)printf("%07d\n",*it);//注意格式化输出的时候给定长度 
	}
}
int main()
{
	int id;
	string ttitle,tauthor,tkeywords,tpublisher,tyear;
	cin>>bookNum;
	for(int i=0;i<bookNum;i++){
		scanf("%d\n",&id);//scanf也会把回车放入缓冲区,这里直接读了 
		getline(cin,ttitle);
		title[ttitle].insert(id);
		getline(cin,tauthor);
		author[tauthor].insert(id);
		/*getline()中的结束符,结束后,结束符不放入缓存区;
		cin的结束符,结束后,结束符还在缓存区*/
		while(cin>>tkeywords){
			keywords[tkeywords].insert(id);
			char temp=getchar();
			if(temp=='\n')break;
		}//关键词的个数没有给定,需要每次在用cin接收输入后,再用getchar()判断下一个字符是不是'\n' 
		getline(cin,tpublisher);
		publisher[tpublisher].insert(id);
		getline(cin,tyear);
		year[tyear].insert(id);
	}
	cin>>queryNum;
	int index;
	string target;
	for(int i=0;i<queryNum;i++){
		scanf("%d: ",&index);
		printf("%d: ",index);
		getline(cin,target);
		cout<<target<<'\n';
		if(index==1)query(title,target);
		else if(index==2)query(author,target);
		else if(index==3)query(keywords,target);
		else if(index==4)query(publisher,target);
		else if(index==5)query(year,target);
	}
}

标签:string,30,cin,Library,getline,book,Digital,keywords,id
来源: https://blog.csdn.net/weixin_48954087/article/details/114156249

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有