ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT 1027 Colors in Mars

2021-02-18 12:02:38  阅读:193  来源: 互联网

标签:digits digit PAT color res 1027 Colors Mars output


目录

问题描述

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for , the middle 2 digits for , and the last 2 digits for . The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.RedGreenBlue

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output , then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a to its left.#0

Sample Input:
15 43 71
Sample Output:
#123456

思路分析及代码实现

li = {0: '0', 1: '1', 2: '2', 3: '3', 4: '4', 5: '5', 6: '6', 7: '7', 8: '8', 9: '9', 10: 'A', 11: 'B', 12: 'C'}
res = '#'
for i in range(3):
    n = int(input())
    res += li[n // 13] + li[n % 13]
print(res)

标签:digits,digit,PAT,color,res,1027,Colors,Mars,output
来源: https://blog.csdn.net/qaqlalala/article/details/113844392

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有