ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

WERTYU UVA - 10082

2021-01-30 20:32:26  阅读:203  来源: 互联网

标签:字符 int typed keyboard WERTYU 10082 数组 Input UVA


​   A common typing error is to place the hands on the keyboard one row to the right of the correct position. So ‘Q’ is typed as ‘W’ and ‘J’ is typed as ‘K’ and so on. You are to decode a message typed in this manner.

Input

​   Input consists of several lines of text. Each line may contain digits, spaces, upper case letters (except Q, A, Z), or punctuation shown above [except back-quote (‘)]. Keys labelled with words [Tab, BackSp, Control, etc.] are not represented in the input.

Output

​   You are to replace each letter or punction symbol by the one immediately to its left on the ‘QWERTY’ keyboard shown above. Spaces in the input should be echoed in the output.

Sample Input

O S, GOMR YPFSU/

Sample Output

I AM FINE TODAY.

HINT

​​   运用字符传比较。将所有的键盘上的字符存储到一个数组上,循环比较每一个字符是否是与数组上面的对应。若对应打印数组上对应字符位置的前一个字符。若没有打印自己。

Accepted

#include<stdio.h>
#include<string.h>

int main()
{
    char s[80]="`1234567890-=QWERTYUIOP[]\\ASDFGHJKL;'ZXCVBNM,./";
    char ch;
    int len=strlen(s);
    while(scanf("%c",&ch)!=EOF)
    {
        int flag=0;
        for(int i=0;i<len;i++)
        {
            if(ch==s[i])
                {
                    printf("%c",s[i-1]);
                    flag=1;
                    break;
                }
        }
        if(!flag)putchar(ch);
    }
}

标签:字符,int,typed,keyboard,WERTYU,10082,数组,Input,UVA
来源: https://www.cnblogs.com/3236676588buladuo/p/14350319.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有