ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

ACM----HDU-1241 dfs2

2021-01-29 21:05:54  阅读:180  来源: 互联网

标签:1241 HDU oil int ---- grid && vx 油井


Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘’*’, representing the absence of oil, or `@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

解题思路:两个相邻的含油油井属于同一个油井,想要解出区域内有多少个不同的油井。只需在碰到含油的油井时,遍历它周围的八个油井,将有油的点归零,之后将计数器加一,遍历完所有有油的油井后,输出计数器的值即为所求。

#include<cstdio>
#include<iostream>
using namespace std;
char map[200][200];
int num=0;
int m=0,n=0;
int xc[8]={1,1,0,-1,-1,-1,0,1};
int yc[8]={0,-1,-1,-1,0,1,1,1};
void dfs(int x, int y)
{
    map[x][y] = '*';
    for(int i = 0; i < 8; i++){//寻找该油井周围的八个油井
        int vx=x+xc[i];
        int vy=y+yc[i];
        if (map[vx][vy] == '@' && vx < m && vx >= 0 && vy < n && vy >= 0) dfs(vx, vy);
    }
}
int main(){

    while(scanf("%d%d",&m,&n)!=EOF&&m!=0&&n!=0){
        num=0;
        for(int i=0;i<m;i++){
            for(int j=0;j<n;j++){
                cin>>map[i][j];
            }
        }
      for(int i=0;i<m;i++){
        for(int j=0;j<n;j++){
            if(map[i][j]=='@'){
                dfs(i,j);num++;
            }
        }
    }
        printf("%d\n",num);
    }
   return 0;
}

 

标签:1241,HDU,oil,int,----,grid,&&,vx,油井
来源: https://www.cnblogs.com/jin0622/p/14346995.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有