ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PAT Advanced 1009 Product of Polynomials

2021-01-24 14:35:13  阅读:199  来源: 互联网

标签:count Product PAT int 0.0 result 1009 exponents coefficients


题目

1009 Product of Polynomials (25分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N1 a**N1 N2 a**N2 ... N**K aNK

where K is the number of nonzero terms in the polynomial, N**i and aNi (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N**K<⋯<N2<N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

理解与算法

多项式乘法,思路也不难,遍历两个多项式,相乘即可,M*N的复杂度,需要考虑的是存储方式。

题目里给出的范围是1-1000,所以数组大小设置为2001就足够了,但是,如果指数范围非常大,大到几万,几十万,就不太好用数组来实现,可以考虑用map来实现。

代码与实现

//
// Created by tanknee on 2021/1/24.
//

#include <iostream>
#include <map>

using namespace std;

int main() {
    int count, exponents;
    double coefficients, m1[1001] = {0.0}, result[2001] = {0.0};
    cin >> count;
    for (int i = 0; i < count; ++i) {
        cin >> exponents >> coefficients;
        m1[exponents] = coefficients;
    }
    cin >> count;
    for (int i = 0; i < count; ++i) {
        cin >> exponents >> coefficients;
        for (int j = 0; j < 1001; ++j) {
            if (m1[j] != 0.0)
                result[j + exponents] += m1[j] * coefficients;
        }
    }
    count = 0;
    for (int i = 2000; i >= 0; i--) {
        if (result[i] != 0.0)
            count++;
    }
    printf("%d", count);
    for (int i = 2000; i >= 0; i--) {
        if (result[i] != 0.0)
            printf(" %d %.1f", i, result[i]);
    }
    return 0;
}

标签:count,Product,PAT,int,0.0,result,1009,exponents,coefficients
来源: https://www.cnblogs.com/tanknee/p/14320813.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有