ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

ACboy needs your help again! 航电1702 map

2021-01-22 09:31:37  阅读:212  来源: 互联网

标签:shop again needs help int rank memory line contians


Shopping

*Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8470 Accepted Submission(s): 3020
*

Problem Description

Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called “memory”. Now she wants to know the rank of this shop’s price after the change of everyday.

Input

One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.

Output

Contains m lines ,In the ith line print a number of the shop “memory” ‘s rank after the ith day. We define the rank as :If there are t shops’ price is higher than the “memory” , than its rank is t+1.

Sample Input

3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory

Sample Output

1
2

题解

用map记录每个商店的价格
每天都遍历一遍,找出比memory价格高的商店的数量

#include <iostream>
#include <map>
#include <set>
using namespace std;
int main()
{
    int N, M;
    while (cin >> N)
    {

        map<string, int> rank;
        string s;
        for (int i = 1; i <= N; i++)
            cin >> s;
        cin >> M;
        int x;
        while (M--)
        {
            for (int i = 1; i <= N; i++)
            {
                cin >> x >> s;
                rank[s] += x;
            }
            int i = 1;
            for (auto e : rank)
                if (e.second > rank["memory"])
                    i++;
            cout << i << endl;
        }
    }
    return 0;
}

标签:shop,again,needs,help,int,rank,memory,line,contians
来源: https://blog.csdn.net/weixin_45653525/article/details/112977012

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有