ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

2020-12-15

2020-12-15 12:00:27  阅读:223  来源: 互联网

标签:lf 12 15 int double scanf pol num 2020


PATA 1009 Product of Polynomials (25分)

题目描述:This time, you are supposed to find A×B where A and B are two polynomials.


输入格式:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ a​N​1​​ N​2​​ a​N​2​​ ​​ … N​K​​ a​N​K where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000…

输出格式:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

输入样例:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

输出样例:

3 3 3.6 2 6.0 1 1.6

题意:多项式对应的项相乘
思路:记录每个项再对应相加,简单题。
注意输入的&和输出对应的数据类型%lf!
优化:可以只用1个数组,可参考柳神的代码
注意判断double类型用0.0 虽然与0的效果一样,但0.0更准确

代码:

#include <iostream>
using namespace std;
int main(){
	int a,b;
	double pola[1001]={0},polb[1001]={0},pol[2001]={0};
	scanf("%d",&a);
	for(int i=0;i<a;i++){
		int num;
		double k;
		scanf("%d %lf",&num,&k);
		pola[num] = k; 
	}
	scanf("%d",&b);
	for(int i=0;i<b;i++){
		int num;
		double k;
		scanf("%d %lf",&num,&k); 
		polb[num] = k; 
	}
	for(int i=1000;i>=0;i--){
		for(int j=1000;j>=0;j--){
			pol[i+j] += pola[i]*polb[j];
		}
	}
	
	int n=0;//记录不为0 
	for(int i=0;i<2001;i++){		
		if(pol[i]!=0){
			n++;
		}
	}
	printf("%d",n);
	for(int i=2000;i>=0;i--){
		if(pol[i]!=0.0){
			printf(" %d %.1lf",i,pol[i]);
		}
	}	
	return 0;
} 
} 

GOGOGOGO!
Love Joyee forever!今天红薯,麻辣烫,烤鸡翅!

标签:lf,12,15,int,double,scanf,pol,num,2020
来源: https://blog.csdn.net/weixin_43743670/article/details/111195880

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有