ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Oil Deposits 油藏

2020-12-05 23:03:11  阅读:218  来源: 互联网

标签:oil 油藏 int Deposits dfs 网格 Oil grid


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 63433 Accepted Submission(s): 36432

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the absence of oil, or ’@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1*3 5*@*@***@***@*@*
5 5****@*@@*@*@**@@@@*@@@**@0 0

Sample Output
0
1
2
2

Source
Mid-Central USA 1997

Recommend
Eddy

油藏
时间限制:2000/1000 MS(Java /其他)内存限制:65536/32768 K(Java /其他)
提交总数:60005接受提交:34416

问题描述
GeoSurvComp地质勘测公司负责检测地下油藏。 GeoSurvComp一次处理一个大矩形区域的土地,并创建一个将土地划分为多个正方形图的网格。然后,它使用传感设备分别分析每个地块,以确定该地块是否包含油。包含油的地块称为矿穴。如果两个凹坑相邻,则它们是同一油藏的一部分。积油可能很大,可能包含许多凹穴。您的工作是确定网格中包含多少种不同的油藏。

输入值
输入文件包含一个或多个网格。每个网格均以包含m和n的行开始,网格中的行和列数为m和n,并用单个空格分隔。如果m = 0,则表示输入结束;否则,输入0。否则为1 <= m <= 100和1 <= n <=100。紧随其后的是m行,每行n个字符(不计算行尾字符)。每个字符对应一个地块,要么是代表无油的“ *”,要么是代表油囊的“ @”。

输出量
对于每个网格,输出不同的油藏数量。如果两个不同的油藏在水平,垂直或对角线上相邻,则它们是同一油藏的一部分。积油最多可容纳100个口袋。

样本输入

在这里插入图片描述

样本输出
0
1
2
2

题解:

#include <stdio.h>
int n,m;
char a[105][105];
void dfs(int i,int j)
{
	if(a[i][j]!='@'||i<0||j<0||i>=m||j>=n)//注意要防止搜索越界
	    return;
	else
	{
		a[i][j]='A';//随便用一个非"@"的字符标注为已经搜索
		dfs(i-1,j-1);//向左上进行搜索
		dfs(i-1,j);//上
		dfs(i-1,j+1);//左下
		dfs(i,j-1);//左
		dfs(i,j+1);//右
		dfs(i+1, j-1);//右上
		dfs(i+1,j);//右
		dfs(i+1,j+1);//右下
	}
	
}
int main()
{
	int i,j,sum;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
	    sum=0;
		if(m==0||n==0)
			break;
		for(i=0;i<m;i++)
	    {
			scanf("%s",a[i]);
		}
	    for(i=0;i<m;i++)
	    {
	    	for(j=0;j<n;j++)
	    	{
	    		if(a[i][j]=='@')
	    		{
	    			dfs(i,j);
	    			sum++;//搜索结束,记录数目
				}
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

总结:此题用深入优先搜索(DFS)解题
1.不要忘了深搜时越界的避免。
2.对周围进行搜索可以用八个dfs。

标签:oil,油藏,int,Deposits,dfs,网格,Oil,grid
来源: https://blog.csdn.net/weixin_50913860/article/details/110728479

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有