ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

C - How Many Tables 杭电oj_____1213

2020-12-05 20:59:44  阅读:185  来源: 互联网

标签:Tables Ignatius oj _____ f1 int f2 num knows


How Many Tables

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.
One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.
For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

这道题是说,已知会告诉你各个独立集的关系,通过这些关系的作用之后,会留下多少个独立的集合!
根据已知条件我们可以讲有关系的集合进行合并,最后看谁的祖先是本身,就说明它将会是一个独立集!

代码:

#include<stdio.h>
#define M 1009
int p[M];
void init(int n)
{
    int i;
    for(i=1; i<=n; i++)
        p[i]=i;
}
int fond_root(int a)
{
    int i,r=a;
    while(p[r]!=r)
    {
        r=p[r];
    }
    while(a!=r)
    {
        i=p[a];
        p[a]=r;
        a=i;
    }
    return a;
}
int main()
{
    int i,j,n,m,t,k,a,b,num,f1,f2;
    scanf("%d",&t);
    for(k=1; k<=t; k++)
    {
        scanf("%d%d",&n,&m);
        init(n);
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            f1=fond_root(a);
            f2=fond_root(b);
            if(f1!=f2)
                p[f1]=f2;
        }
        num=0;
        for(j=1; j<=n; j++)
        {
            if(p[j]==j)
                num++;
        }
        printf("%d\n",num);
    }
    return 0;
}

标签:Tables,Ignatius,oj,_____,f1,int,f2,num,knows
来源: https://blog.csdn.net/CHEN_XU_LING/article/details/110726070

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有