ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

【状压dp】poj3254 Corn Fields

2020-11-30 23:36:34  阅读:232  来源: 互联网

标签:plant include int Fields Corn 状压 ways choose squares


Corn Fields
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 25168   Accepted: 13165

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.       状压dp模板题   代码
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mod=1e9;
int st[1005],cnt,n,m,cur[15],dp[15][1005];
bool judge(int x,int y)
{
    if(x&cur[y]) return false;
    return true;
}
int main()
{
    freopen("a.in","r",stdin);
    freopen("a.out","w",stdout);
    scanf("%d%d",&n,&m);
    int q=1<<m;
    for(int i=0;i<q;i++)
    {
        if(i&(i<<1))continue;
        st[++cnt]=i;
    }
    int x;
    for(int i=1;i<=n;i++)
    {
        cur[i]=0;
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&x);
            if(!x)
                cur[i]+=(1<<(m-j));
        }
    }
    for(int i=1;i<=cnt;i++)
        if(judge(st[i],1))
            dp[1][i]=1;
    for(int i=2;i<=n;i++)
        for(int j=1;j<=cnt;j++)
        {
            if(judge(st[j],i)==false) continue;
            for(int k=1;k<=cnt;k++)
            {
                if(judge(st[k],i-1)==false) continue;
                if(st[k] & st[j]) continue;
                dp[i][j]=(dp[i][j]+dp[i-1][k])%mod;
            }
        }
    int res=0;
    for(int i=1;i<=cnt;i++)
        res=(res+dp[n][i])%mod;
    printf("%d\n",res);
    return 0;
}

 

标签:plant,include,int,Fields,Corn,状压,ways,choose,squares
来源: https://www.cnblogs.com/andylnx/p/14065591.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有