ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1139 First Contact (30分)

2020-05-03 14:56:45  阅读:364  来源: 互联网

标签:1139 Contact 30 2002 2003 2001 1003 1001 first


Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
 

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

这道题考的是找朋友,已知一个图,我们可以用map进行构建朋友圈,我们要求解的是查询的两个人的朋友是否是朋友(通过朋友的朋友间接接触)。我们进行判断的时候,要排除对方自己。这是3个测试点

#include <iostream>
#include <vector>
#include <cstring>
#include <unordered_map>
#include <unordered_set>
#include <algorithm>
using namespace std;
int N, M, K;
char a[10], b[10];
unordered_map<string, unordered_set<string>> frien;
unordered_map<string, unordered_set<string>> homo;
int main() {
    scanf("%d%d", &N, &M);
    while(M--) {
        scanf("%s%s", a, b);
        frien[a].insert(b);
        frien[b].insert(a);
        if(strlen(a) == strlen(b)) {
            homo[a].insert(b);
            homo[b].insert(a);
        }
    }
    scanf("%d", &K);
    while(K--) {
        scanf("%s%s", a, b);
        vector<pair<string, string>> v;
        for(auto x: homo[a]) 
            for(auto y: homo[b]) 
                if(x != b && y != a && frien[x].find(y) != frien[x].end()) 
                    v.push_back({x, y});
        sort(v.begin(), v.end());
        printf("%lu\n", v.size());
        for(auto x: v) {
            if(x.first.length() == 5) x.first = x.first.substr(1);
            if(x.second.length() == 5) x.second = x.second.substr(1);
            printf("%s %s\n", x.first.c_str(), x.second.c_str());
        }
    }
    return 0;
}

 

标签:1139,Contact,30,2002,2003,2001,1003,1001,first
来源: https://www.cnblogs.com/littlepage/p/12821908.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有