ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1155 Heap Paths

2020-03-21 21:52:41  阅读:272  来源: 互联网

标签:Paths temp 10 1155 Sample 98 int Heap root


题干前半略。

Sample Input 1:

8
98 72 86 60 65 12 23 50
 

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap
 

Sample Input 2:

8
8 38 25 58 52 82 70 60
 

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap
 

Sample Input 3:

8
10 28 15 12 34 9 8 56
 

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap


#include<stdio.h>
#include<algorithm>
#include<vector>

using namespace std;

int seq[1005];
vector<int> result[1005];
vector<int> temp;
int num;
int c;
void dfs(int root)
{
    if(root*2+1>num) 
    {
        temp.push_back(seq[root]);
        result[c]=temp;
        c++;
        temp.pop_back();
        return ;
    }
    temp.push_back(seq[root]);
    if(root*2+2<num) dfs(root*2+2);
    if(root*2+1<num) dfs(root*2+1);
    temp.pop_back();
    return ;
}
int mark;
bool flag;
int main()
{
    
    scanf("%d",&num);
    for(int i=0;i<num;i++)
    {
        scanf("%d",&seq[i]);
    }
    dfs(0);
    if(seq[0]<seq[1]) mark=-1;  //minheap
    else mark=1; //maxheap
    for(int i=0;i<c;i++)
    {
        for(int t=0;t<result[i].size();t++)
        {
            if(t!=0)
            {
                if(mark==1)
                {
                    if(result[i][t]>result[i][t-1]) flag=true;
                }
                else if(mark==-1)
                {
                    if(result[i][t]<result[i][t-1]) flag=true;
                }
            }
            printf("%d",result[i][t]);
            if(t!=result[i].size()-1) printf(" ");
        }
        printf("\n"); 
    }
    if(flag==true)
    {
        printf("Not Heap");
    }
    else
    {
        if(mark==1) printf("Max Heap");
        else printf("Min Heap");
    }
    
}

 

标签:Paths,temp,10,1155,Sample,98,int,Heap,root
来源: https://www.cnblogs.com/zzzlight/p/12542519.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有