ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1146 Topological Order (25分) (判断序列是否为拓扑排序)

2020-03-15 15:39:33  阅读:274  来源: 互联网

标签:25 1146 int graph vertices Topological each line 1001


 

1146 Topological Order (25分)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

题目大意:给出一组图的有向边,再给出k组序列,让你判断哪些不是拓扑排序 

思路:用vector数组存储图,inDegree[]数组记录每个点的入度,arr[]数组存储要检查序列

循环检查arr中的每一个点,如果入度不为0就break,把每个点指向的所有点入度减1

完整代码:

#include <iostream>
#include <vector>
#include <queue>
using namespace std;
vector<int> g[1001];
int n,m,k,arr[1001],inDegree[1001];
int main(){
    cin>>n>>m;
    int u,v,temp[1001] = {0},res[101];
    int cnt = 0;
    for(int i = 0;i<m;i++){
        scanf("%d%d",&u,&v);
        g[u].push_back(v);
        temp[v]++;
    }
    cin>>k;
    for(int i = 0;i<k;i++){
        //记得每次都要重新赋值inDegree数组
        for(int j = 1;j<=n;j++){
            inDegree[j] = temp[j];
        }
        for(int j = 1;j<=n;j++){
            scanf("%d",&arr[j]);
        }
        for(int j = 1;j<=n;j++){
            //入度不为0就不能形成拓扑排序
            if(inDegree[arr[j]]!=0){
                res[cnt++] = i;
                break;
            }
            //该点指向的所有点入度减1
            for(int u = 0;u<g[arr[j]].size();u++){
                int v = g[arr[j]][u];
                inDegree[v]--;
            }
        }
    }
    bool flag = false;
    for(int i = 0;i<cnt;i++){
        if(flag==false){
            cout<<res[i];
            flag = true;
        }
        else {
            cout<<" "<<res[i];
        }
    }
    return 0;
}

 

标签:25,1146,int,graph,vertices,Topological,each,line,1001
来源: https://blog.csdn.net/qq_40167974/article/details/104879388

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有