ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

hdu 2057 A + B Again

2020-03-10 10:07:31  阅读:258  来源: 互联网

标签:Again hdu const I64X 2057 int 1A hexadecimal include


Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A +1A 12 1A -9 -1A -12 1A -AA

Sample Output

0 2C 11 -2C -90 解:这个题可以用字符串转成10进制数,相加后再输出16进制数。有一种更简单的实现方法,直接懂%X输入输出,但问题是16进制数没有符号位,所以正负要分开。
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=1e5+10;
const int mod=1e9+7;

int main(){
    __int64 a,b,c;
    while(scanf("%I64X %I64X ",&a,&b)!=EOF){
        c=a+b;
        if(c>=0)printf("%I64X\n",c);
        else printf("-%I64X\n",-c);
    }
    return 0;
}

 

标签:Again,hdu,const,I64X,2057,int,1A,hexadecimal,include
来源: https://www.cnblogs.com/wz-archer/p/12453921.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有