ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HDU 1260 动态规划

2020-03-03 15:03:10  阅读:294  来源: 互联网

标签:tickets HDU 动态 08 1260 am Joe time include


Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13794    Accepted Submission(s): 6774


Problem Description Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.  

 

Input There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.  

 

Output For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.  

 

Sample Input 2 2 20 25 40 1 8  

 

Sample Output 08:00:40 am 08:00:08 am   AC代码
#include<iostream>
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<algorithm>
#include<cstring>
typedef long long ll;
using namespace std;
int a[2005],ans,b[2005],dp[2005],k,n;
int main(){
    cin>>n;
    while(n--){
        cin>>k;
        dp[0]=0;
        for(int i=1;i<=k;++i)scanf("%d",&a[i]);
        for(int i=2;i<=k;++i)scanf("%d",&b[i]);
        dp[1]=a[1];
        for(int i=2;i<=k;++i)dp[i]=min(dp[i-1]+a[i],dp[i-2]+b[i]); 
        ans=dp[k];
        int h=ans/3600+8;int m=(ans-(h-8)*3600)/60;int s=(ans-(h-8)*3600)%60;
        if(h<12)
        printf("%02d:%02d:%02d am\n",h,m,s);
        else
        printf("%02d:%02d:%02d pm\n",h%12,m,s);
    }
    return 0;
}

 

标签:tickets,HDU,动态,08,1260,am,Joe,time,include
来源: https://www.cnblogs.com/m2364532/p/12402367.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有