ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

I Think I Need a Houseboat

2020-02-29 19:54:25  阅读:211  来源: 互联网

标签:semicircle land int will year Need property Think Houseboat


Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)

Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2
1.0 1.0
25.0 0.0

Sample Output

Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.

Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.
2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.
3.All locations are given in miles.   题解: 在提交过程中,发现某些编译器不写#include<cmath>等头文件没有问题,而在做题时,这些头文件不可省略 #define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<cmath>
using namespace std; int main()
{
 int n;
 cin >> n;
 double x, y;
 double* d = new double[n];
 int max=0;
 
 for (int i = 0; i < n; i++) {
  cin >> x >> y;
  d[i] = sqrt(x * x + y * y);
 }
 for (int i = 0; i < n; i++) {
  d[i] = d[i] * d[i] * 3.14;
  cout << "Property " << i + 1 << ": This property will begin eroding in year " << (int)(d[i] / 100 + 1) << "." << endl;
 }
 cout << "END OF OUTPUT." << endl;
 return 0;
}

标签:semicircle,land,int,will,year,Need,property,Think,Houseboat
来源: https://www.cnblogs.com/lijiahui-123/p/12384913.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有