ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1012 The Best Rank (25分)

2020-02-29 10:39:47  阅读:257  来源: 互联网

标签:25 stu int Rank rank students Best 91 best


1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

 

/*
刚开始写的时候陷入了一个误区,那就是只保存一个排名,同时记录所选用
的排名编号,阅读别人的博客之后发现可以同时保存不同种类分数排名,
记录最好的种类的下标;
思路如下:
因为存在四种分数,所以结构体中定义大小为4的分数数组,和排名数组
记录顺序分别为ACME,对应下标0123
有相同分数时,排名为1,1,3,4,5,而不是1,1,2,3,4
对分数进行四舍五入,应该除以3.0而不是3,再加上0.5
 定义一个数组记录ID对应的编号,编号时需要注意,
假设ID对应的编号为0则表示不存在,所以编号时不能编号为0,
博主代码现将编号+1,最后输出再将编号-1。 
*/
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include<map>
using namespace std;
struct node{
	int score[4];
	int rank[4];
	int best,id;
}stu[2005];
int flag =0;
int mp[1000000];
bool cmp(const node &a,const node &b){
	return a.score[flag] > b.score[flag];
}
int main(){
//	freopen("input.txt","r",stdin);
	int n,m,id;
	scanf("%d%d",&n,&m);
	for(int i = 0;i<n;i++){
		scanf("%d%d%d%d",&stu[i].id,&stu[i].score[1],&stu[i].score[2],&stu[i].score[3]);
		stu[i].score[0] = (stu[i].score[1]+stu[i].score[2]+stu[i].score[3])/3.0+0.5;
	}
	for(flag = 0;flag < 4;flag++){
		sort(stu,stu+n,cmp);
		stu[0].rank[flag] = 1;
		for(int i = 1;i < n;i++){
			stu[i].rank[flag] = i+1;
			if(stu[i].score[flag] == stu[i-1].score[flag]){
				stu[i].rank[flag] = stu[i-1].rank[flag];
			}
		}
	}
	for(int i = 0;i < n;i++){
		mp[stu[i].id] = i+1;
		stu[i].best = 0;
		int minn = stu[i].rank[0];
		for(int j = 1;j < 4;j++){
			if(minn > stu[i].rank[j]){
				minn = stu[i].rank[j];
				stu[i].best = j;
			}
		}
	}
	string r="ACME";
	for(int i = 0;i < m;i++){
		scanf("%d",&id);
		int temp = mp[id];
		if(!temp){
			printf("N/A\n");
		}else{
			int t = stu[temp-1].best;
			printf("%d %c\n",stu[temp-1].rank[t],r[t]);
		}
	}
	return 0;
}

 

取次花丛懒回顾_半缘修道半缘君 发布了300 篇原创文章 · 获赞 55 · 访问量 8万+ 私信 关注

标签:25,stu,int,Rank,rank,students,Best,91,best
来源: https://blog.csdn.net/PriestessofBirth/article/details/104353430

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有