ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

平面上的点——Point类 (II)

2020-01-29 21:06:32  阅读:350  来源: 互联网

标签:erased 输出 show created Point II 坐标 平面


Description
在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定。现在我们封装一个“Point类”来实现平面上的点的操作。

根据“append.cc”,完成Point类的构造方法和show()方法,输出各Point对象的构造和析构次序。

接口描述:
Point::show()方法:按输出格式输出Point对象。

Input
输入多行,每行为一组坐标“x,y”,表示点的x坐标和y坐标,x和y的值都在double数据范围内。

Output
输出每个Point对象的构造和析构行为。对每个Point对象,调用show()方法输出其值:X坐标在前,Y坐标在后,Y坐标前面多输出一个空格。每个坐标的输出精度为最长16位。输出格式见sample。

C语言的输入输出被禁用。

Sample Input

1,2
3,3
2,1

Sample Output

Point : (0, 0) is created.
Point : (1, 2) is created.
Point : (1, 2) Point : (1, 2) is erased.
Point : (3, 3) is created.
Point : (3, 3)
Point : (3, 3) is erased.
Point : (2, 1) is created.
Point : (2, 1)
Point : (2, 1) is erased.
Point : (0, 0) is copied.
Point : (1, 1) is created.
Point : (0, 0) Point : (1, 1)
Point : (0, 0) Point : (1, 1) is erased.
Point : (0, 0) is erased.
Point : (0, 0) is erased.

HINT
思考构造函数、拷贝构造函数、析构函数的调用时机。

append.cc

int main()
{
    char c;
    double a, b;
    Point q;
    while(std::cin>>a>>c>>b)
    {
        Point p(a, b);
        p.show();
    }
    Point q1(q), q2(1);
    q1.show();
    q2.show();
    q.show();
}

答案

#include <iostream>
#include<iomanip>
using namespace std;
class Point
{
private:
    double x,y;
public:
    Point()
    {
        x=0;
        y=0;
        cout<<setprecision(16)<<"Point : (0, 0) is created."<<endl;
    }
    Point(int _x,int _y)
    {
        x = _x;
        y = _y;
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")is created."<<endl;
    }
    Point(int _x)
    {
        x=_x;
        y=_x;
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")is copied."<<endl;

    }
    ~Point ()
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")is erased."<<endl;
    }
    Point(Point const &p)
    {
        x=p.x;
        y=p.y;
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")is copied."<<endl;

    }
    void show()
    {
        cout<<setprecision(16)<<"Point : ("<<x<<", "<<y<<")"<<endl;
    }
};
Time like water 发布了35 篇原创文章 · 获赞 1 · 访问量 1039 私信 关注

标签:erased,输出,show,created,Point,II,坐标,平面
来源: https://blog.csdn.net/qq_43839907/article/details/104089025

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有