ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

HDU 1005

2020-01-27 19:42:34  阅读:245  来源: 互联网

标签:HDU return int d% single test Input 1005


Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output
For each test case, print the value of f(n) on a single line.

Sample Input
1 1 3
1 2 10
0 0 0

Sample Output
2
5

Submission


#include <iostream>
int A,B;
int f(int n){
	if( n == 1 || n == 2){
		return 1;
	}
	return (A*f(n-1)+B*f(n-2))%7;
}
int main(){
 
	int n;
	while(scanf("%d%d%d",&A,&B,&n)!=EOF,A||B||n){
		int a = f(n%49);
		printf("%d\n",a);
	}
}

langman5288 发布了9 篇原创文章 · 获赞 3 · 访问量 383 私信 关注

标签:HDU,return,int,d%,single,test,Input,1005
来源: https://blog.csdn.net/langman5288/article/details/104094899

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有