ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Oil Deposits 新年特辑篇

2020-01-23 12:50:50  阅读:273  来源: 互联网

标签:Oil int Deposits dfs deposits oil grid 特辑 include


 

链接:E - Oil Deposits

题目:

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2

翻译:给你一块地图 ,其中' @ '代表探测到有油的地方, 而' * '则是代表没有油的地方。
现在题目给出了油田的定义,所有连在一起的' @ ' 代表一个油田, 而连在一起的定义是有公共点或公共边。
而题目的要求是输出给你一张地图上的油田的个数。

思路:常规的搜索题,不过不再是4个方向,而是8个方向

搞下代码:
#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <queue>//能想到的头文件都写了 害怕错 
int dir[8][2]={{1,0},{1,1},{0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1}};//坐标轴上的8个方向 
char mapp[105][105];
int n,m;
void dfs(int x,int y)//dfs 深度搜索  x为横 y为纵 
{
    if(mapp[x][y]=='@')//将搜过的口袋标记 //如果为@ 则 标记为* 
        mapp[x][y]='*';
    for(int i=0;i<8;i++)//八个方向搜索 所以i为8 
    {
        int a=dir[i][0]+x;//横坐标改变
        int b=dir[i][1]+y;//纵坐标
        if(mapp[a][b]=='@'&&a<n&&a>=0&&b<m&&b>=0)//满足条件:是口袋且横纵坐标都在范围内 则进行搜索 
            dfs(a,b);
    }
}
int main()
{
    while(scanf("%d %d",&n,&m)&&n!=0&&m!=0)
    {
        int sum=0;//一开始设置为0 
        getchar();
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                scanf("%c",&mapp[i][j]);
            getchar();
        }
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
        {
            if(mapp[i][j]=='@')//遇到口袋进行搜索
            {
                dfs(i,j);
                sum++;//每次搜索完后 进行+1 
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

这道题的话dfs与bfs都可以,但这种题我觉得dfs显得更简单些(maybe)

顺便祝大家新年快乐。

 









标签:Oil,int,Deposits,dfs,deposits,oil,grid,特辑,include
来源: https://www.cnblogs.com/sidenynb/p/12230465.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有