ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

Accepted Necklace//HDU - 2660//dfs

2020-01-13 20:42:13  阅读:355  来源: 互联网

标签:HDU include weight int dfs maxn each Necklace Accepted


Accepted Necklace//HDU - 2660//dfs


题目

I have N precious stones, and plan to use K of them to make a necklace for my mother, but she won’t accept a necklace which is too heavy. Given the value and the weight of each precious stone, please help me find out the most valuable necklace my mother will accept.
Input
The first line of input is the number of cases.
For each case, the first line contains two integers N (N <= 20), the total number of stones, and K (K <= N), the exact number of stones to make a necklace.
Then N lines follow, each containing two integers: a (a<=1000), representing the value of each precious stone, and b (b<=1000), its weight.
The last line of each case contains an integer W, the maximum weight my mother will accept, W <= 1000.
Output
For each case, output the highest possible value of the necklace.
Sample Input
1
2 1
1 1
1 1
3
Sample Output
1
题意
串项链,重量之内价值尽可能高
链接:http://acm.hdu.edu.cn/showproblem.php?pid=2660

思路

dfs,重量作为判断条件即可

代码

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <string>

using namespace std;
pair<int,int> neck[30];
int n,t,k,W;
int maxn=0;
void dfs(int weight,int temp,int left,int price){
    if(weight>W||temp>=n) return;
    if(left==0){
        if(price>maxn) maxn=price;
        return ;
    }
    for(int i=temp;i<n;i++){
        dfs(weight+neck[i].second,i+1,left-1,price+neck[i].first);
    }
}
int main()
{
    cin>>t;
    for(int i=0;i<t;i++){
        cin>>n>>k;
        for(int j=0;j<n;j++){
            cin>>neck[j].first>>neck[j].second;
        }
        cin>>W;
        maxn=0;
        dfs(0,0,k,0);
        cout<<maxn<<endl;
    }
    return 0;
}

注意

salty_fishman 发布了14 篇原创文章 · 获赞 9 · 访问量 192 私信 关注

标签:HDU,include,weight,int,dfs,maxn,each,Necklace,Accepted
来源: https://blog.csdn.net/salty_fishman/article/details/103963710

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有