ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

H - Horror Film Night Kattis - horrorfilmnight

2020-01-13 09:43:18  阅读:328  来源: 互联网

标签:Kattis int Horror horrorfilmnight watch Sample ++ they films


H - Horror Film Night

题意:有两个人想去一起看电影,然后分别给出两个人 分别喜欢看的电影都在哪些天,然后, 同一个人 不能连续看两天他不喜欢的电影。
求他们最多可以看多少次电影。

思路:把这两个人喜欢的电影分别标记一下,遍历1e7,
1.如果他们都喜欢,加一;2. 有一个喜欢而且上一场电影自己不喜欢的,加一。

Emma and Marcos are two friends who love horror films. This year, and possibly the years hereafter, they want to watch as many films together as possible. Unfortunately, they do not exactly have the same taste in films. So, inevitably, every now and then either Emma or Marcos has to watch a film she or he dislikes. When neither of them likes a film, they will not watch it. To make things fair they thought of the following rule: They can not watch two films in a row which are disliked by the same person. In other words, if one of them does not like the current film, then they are reassured they will like the next one. They open the TV guide and mark their preferred films. They only receive one channel which shows one film per day. Luckily, the TV guide has already been determined for the next 1 million days.

Can you determine the maximal number of films they can watch in a fair way?

Input
The input consists of two lines, one for each person. Each of these lines is of the following form:

One integer 0≤k≤1000000 for the number of films this person likes;

followed by k integers indicating all days (numbered by 0,…,999999) with a film this person likes.

Output
Output a single line containing a single integer, the maximal number of films they can watch together in a fair way.

Sample Input 1 Sample Output 1
1 40
2 37 42
3
Sample Input 2 Sample Output 2
1 1
3 1 3 2
2
Sample Input 3 Sample Output 3
1 2
1 2
1

#include<bits/stdc++.h>
using namespace std;
#define mm 10000010
int a[mm], b[mm];

int main()
{
    ios::sync_with_stdio(0);
    int n, m;
    cin >> n;
    memset(a, 0, sizeof(a));
    for(int i = 0; i <n; i ++)
    {
        int x;
        cin >>x;
        a[x] = 1;
    }
    cin >> m;
    memset(b, 0, sizeof(b));
    for(int i = 0; i < m; i ++)
    {
        int x;
        cin >> x;
        b[x] = 1;
    }
    int pre1 = 0;
    int pre2 = 0;
    int ans = 0;
    for(int i = 0; i < mm; i ++)
    {
        if(a[i]&&b[i])
        {
            pre1 = 0;
            pre2 = 0;
            ans++;
        }
        else if(a[i]&&!pre1)
        {
            pre2 = 0;
            pre1 = 1;
            ans++;
        }
        else if(b[i]&&!pre2)
        {
            pre2 = 1;
            pre1 = 0;
            ans++;
        }
    }
    cout << ans << endl;
    return 0;
}
耶啵家的肖兔兔 发布了37 篇原创文章 · 获赞 0 · 访问量 523 私信 关注

标签:Kattis,int,Horror,horrorfilmnight,watch,Sample,++,they,films
来源: https://blog.csdn.net/qq_44683599/article/details/103952558

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有