ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

poj-3258 River Hopscotch

2019-10-21 21:53:11  阅读:323  来源: 互联网

标签:3258 int rocks jump poj rock River shortest he


Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input Line 1: Three space-separated integers: L, N, and M
Lines 2.. N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position. Output Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks Sample Input
25 5 2
2
14
11
21
17
Sample Output
4
Hint Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

OJ-ID:
poj-3258

author:
Caution_X

date of submission:
20191017

tags:
二分

description modelling:
一条河有m个石头,每个石头位置a[i](a[0]=0,a[m+1]=n//n是河的长度),从中移除k个石头,最大化两个石头之间的最小值

major steps to solve it:
1.二分枚举石头间距离的最小值,统计达到这个最小值需要移除的石头数
2.如果石头数<=k,所有这个最小距离还可以更大,否则说明这个最小距离过大了


warnings:
当石头数==k时不代表这个最小距离是最优解

AC code:

#include<iostream>
#include<algorithm>
using namespace std;
int a[50005];
int main()
{
    int n,m,k;
    cin>>n>>m>>k;
    a[0]=0;
    a[m+1]=n;
    int L=n;
    for(int i=1;i<=m;i++) {
        cin>>a[i];
        L=min(L,a[i]-a[i-1]);
    }
    L=min(L,a[m+1]-a[m]);
    int R=n;
    sort(a,a+m+2);
    while(L<=R) {
        int mid=(L+R)/2;
        int sum=0,delet=0;
        for(int i=1;i<=m+1;) {
            sum+=a[i]-a[i-1];
            if(sum<=mid) {
                i++;    
                delet++;
            }
            else {
                i++;
                sum=0;
            }
        }
        if(delet<=k) {
            L=mid+1;
        }
        else {
            R=mid-1;
        }
    }
    cout<<L<<endl;
    return 0;
}

 

标签:3258,int,rocks,jump,poj,rock,River,shortest,he
来源: https://www.cnblogs.com/cautx/p/11716493.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有