ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PTA(Basic Level)1058.A+B in Hogwarts

2019-10-14 19:08:57  阅读:370  来源: 互联网

标签:g2 g1 Level 1058 29 Sickle int Hogwarts integer


If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it's easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut (Galleon is an integer in [0,107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:
3.2.1 10.16.27
Sample Output:
14.1.28
思路
  • 题意就是G.S.K形式的货币运算,公式为1G=17S, 1S=29K,按照这个规则相加取余就好了
代码
#include<bits/stdc++.h>
using namespace std;

int main()
{
    int g1, s1, k1;
    int g2, s2, k2;
    cin >> g1 >> s1 >> k1 >> g2 >> s2 >> k2;
    int g, s, k;
    g = g1 + g2;
    s = s1 + s2;
    k = k1 + k2;

    int t = k;
    t = k % 29;
    s += k / 29;
    t = s % 17;
    g += s / 17;
    cout << g << "." << s << "." << k;

    return 0;
}

引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805416519647232

标签:g2,g1,Level,1058,29,Sickle,int,Hogwarts,integer
来源: https://www.cnblogs.com/MartinLwx/p/11673188.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有