ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

PTA(Advanced Level)1046.Shortest Distance

2019-10-10 20:02:50  阅读:281  来源: 互联网

标签:Distance contains 1046 exits Level int between each distance


The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,105]), followed by N integer distances D1 D2 ⋯ DN, where Di is the distance between the i-th and the (i+1)-st exits, and *D**N* is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7
思路
  • 如果设起点、终点分别为x,y ,顺时针的距离就是dis(x,y),逆时针的距离就是dis(y,x),比较就好了。如果是对每一组测试点都手动模拟的话会TLE
  • 所以需要优化,这题的本质是区间和的比较,我们可以另开一个数组记录区间和,那么每次查询的时候只要直接相减就好了
代码
#include<bits/stdc++.h>
using namespace std;
int a[100010] = {0};
int length[100010] = {0};
int main()
{
    int n;
    scanf("%d", &n);
    int sum = 0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d", &a[i]);
        sum += a[i];
        length[i] = sum;
    }
    int m;
    scanf("%d", &m);
    int l, r;
    int t; //暂时存储距离
    while(m--)
    {
        scanf("%d %d", &l, &r);
        if(l > r)   swap(l, r);
        t = length[r-1] - length[l-1];
        printf("%d\n", min(t, sum - t));
    }
    return 0;
}
引用

https://pintia.cn/problem-sets/994805342720868352/problems/994805435700199424

标签:Distance,contains,1046,exits,Level,int,between,each,distance
来源: https://www.cnblogs.com/MartinLwx/p/11650217.html

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有