ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

素数筛总结----基于HDU - 4715(Difference Between Primes)

2019-09-20 18:02:14  阅读:252  来源: 互联网

标签:prime 4715 HDU int even conjecture Between primes include


素数筛模板

void Prime(){
	for(int i=2;2*i<MAX;++i) { prime[2*i]=true; } //任意一个数的两倍都不是素数,于预处理一下。
	for(int i=3;i*i<MAX;i+=2){ //i不考虑是偶数的情况
		if(!prime[i]) {//如果从一开始prime数组就没存i值,则i就是素数
			s[++size]=i; //是素数的保存下来
			for(int j=i*i;j<MAX;j+=i) { prime[j]=true; }//在考虑这个素数的倍数
		}
	}
}

题面

All you know Goldbach conjecture.That is to say, Every even integer greater than 2 can be expressed as the sum of two primes. Today, skywind present a new conjecture: every even integer can be expressed as the difference of two primes. To validate this conjecture, you are asked to write a program.

Input

The first line of input is a number nidentified the count of test cases(n<105). There is a even number xat the next nlines. The absolute value of xis not greater than 106 .

Output

For each number xtested, outputstwo primes aand bat one line separatedwith one space where a-b=x. If more than one group can meet it, output the minimum group. If no primes can satisfy it, output ‘FAIL’.

Sample Input
3
6
10
20
Sample Output
11 5
13 3
23 3
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int V = 1500000;
bool prime[V];
int ans[200] = {2}, sizes = 1;
void Prime()
{
    prime[0] = true;
    prime[1] = true;

    for(int i=2; i*2<V; i++) prime[i*2] = true;
    for(int i=3; i*i<V; i+=2){
        if(!prime[i]){
            ans[sizes++] = i;
            for(int j=i*2; j<V; j += i) prime[j] = true;
        }
    }
}

int main()
{
    Prime();
    int t, n;
    scanf("%d", &t);
    while(t--){
        scanf("%d", &n);
        int flag = 0, ok = 0;
        if(n < 0) flag = 1, n = -n;
        int i;
        for(i=0; i<sizes; i++){
            if(!prime[ans[i]+n]) { ok = 1; break; }
        }
        if(ok) {
            if(flag) printf("%d %d\n", ans[i], ans[i] + n);
            else printf("%d %d\n", ans[i]+n, ans[i]);
        } else{
            printf("FAIL\n");
        }
    }
    return 0;
}

标签:prime,4715,HDU,int,even,conjecture,Between,primes,include
来源: https://blog.csdn.net/weixin_45301032/article/details/101051743

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有