ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

(甲)1041 Be Unique (20 分)

2019-09-03 16:41:47  阅读:233  来源: 互联网

标签:bets 1041 Unique 20 int 31 Sample 88 include


题目:

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题意:

给你一个数字N,后面跟着N个数字,让你找出来第一个没有重复的数字,然后输出来;

如果不存在就输出None;

代码如下:

#include<stdio.h>
#include<string>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

int n,m;
int a[10010];//存储出现的数字出现的次数;
int b[100010];//存储书有的数据;

int main()
{
    while(~scanf("%d",&n))
    {
        memset(a,0,sizeof a);
        memset(b,0,sizeof b);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&b[i]);
            a[b[i]]++;//出现的次数增加;
        }
        int flag=0;
        for(int i=0; i<n; i++)
        {
            if(a[b[i]]==1)//这个数字出现,且出现了一次(即没有重复);
            {
                flag=1;
                printf("%d\n",b[i]);
                break;
            }
        }
        if(flag==0)
            printf("None\n");
    }
    return 0;
}

 

标签:bets,1041,Unique,20,int,31,Sample,88,include
来源: https://blog.csdn.net/titi2018815/article/details/100521360

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有