ICode9

精准搜索请尝试: 精确搜索
首页 > 其他分享> 文章详细

1125 Chain the Ropes

2019-08-31 16:43:40  阅读:246  来源: 互联网

标签:case chain Chain Ropes 1125 rope each integer segments


                                           1125 Chain the Ropes (25 分)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int main()
{
    priority_queue<double,vector<double> ,greater<double> >q;
    int n,e;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>e;
        q.push(e);
    }
    while(q.size()>1)
    {
        double a=q.top();
        q.pop();
        double b=q.top();
        q.pop();
        double t=(a+b)/2;
        q.push(t);
    }
    cout<<(int)q.top()<<endl;
    return 0;
}

 

标签:case,chain,Chain,Ropes,1125,rope,each,integer,segments
来源: https://blog.csdn.net/qq_42681421/article/details/100174235

本站声明: 1. iCode9 技术分享网(下文简称本站)提供的所有内容,仅供技术学习、探讨和分享;
2. 关于本站的所有留言、评论、转载及引用,纯属内容发起人的个人观点,与本站观点和立场无关;
3. 关于本站的所有言论和文字,纯属内容发起人的个人观点,与本站观点和立场无关;
4. 本站文章均是网友提供,不完全保证技术分享内容的完整性、准确性、时效性、风险性和版权归属;如您发现该文章侵犯了您的权益,可联系我们第一时间进行删除;
5. 本站为非盈利性的个人网站,所有内容不会用来进行牟利,也不会利用任何形式的广告来间接获益,纯粹是为了广大技术爱好者提供技术内容和技术思想的分享性交流网站。

专注分享技术,共同学习,共同进步。侵权联系[81616952@qq.com]

Copyright (C)ICode9.com, All Rights Reserved.

ICode9版权所有